nano every and ENC28J60 shield

Hi,

I got a arduino nano every from digikey and a ENC28J60 10M Nano Ethernet Shield from ebay.

https://www.digikey.com/products/en/development-boards-kits-programmers/evaluation-boards-embedded-mcu-dsp/786?k=arduino+nano+every&k=&pkeyword=arduino+nano+every&sv=0&pv1742=314669&sf=0&quantity=&ColumnSort=0&page=1&pageSize=25

https://www.ebay.com/itm/ENC28J60-10M-Nano-Ethernet-Shield-for-Arduino-Compatible-Nano-3-0-RJ45-Webserver/192587051723?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649

After connecting them together, I tried with the blink, that works.
Then I try to get the UIP ethernet echo work.
After installed the UIPEthernet library, I try this code from UIPEthernet example

/*

  • UIPEthernet EchoServer example.
  • UIPEthernet is a TCP/IP stack that can be used with a enc28j60 based
  • Ethernet-shield.
  • UIPEthernet uses the fine uIP stack by Adam Dunkels adam@sics.se

  • This Hello World example sets up a server at 192.168.1.6 on port 1000.
  • Telnet here to access the service. The uIP stack will also respond to
  • pings to test if you have successfully established a TCP connection to
  • the Arduino.
  • This example was based upon uIP hello-world by Adam Dunkels adam@sics.se
  • Ported to the Arduino IDE by Adam Nielsen malvineous@shikadi.net
  • Adaption to Enc28J60 by Norbert Truchsess norbert.truchsess@t-online.de
    */

#include <UIPEthernet.h>
// The connection_data struct needs to be defined in an external file.
#include <UIPServer.h>
#include <UIPClient.h>

EthernetServer server = EthernetServer(1000);

void setup()
{
Serial.begin(9600);

uint8_t mac[6] = {0x00,0x01,0x02,0x03,0x04,0x05};
IPAddress myIP(192,168,1,6);

Ethernet.begin(mac,myIP);

server.begin();
}

void loop()
{
size_t size;

if (EthernetClient client = server.available())
{
if (client)
{
while((size = client.available()) > 0)
{
uint8_t* msg = (uint8_t*)malloc(size);
size = client.read(msg,size);
Serial.write(msg,size);
client.write(msg,size);
free(msg);
}
}
}
}

The compile have warning and uploading seems successful, but I can not ping or telnet that ip.

I also tried the other examples from the file->examples->ethernet, it seems they can compile, load, but not even ping.

Where am I missing here?

BTW, my OS is MACOS Catalina, version 10.15.5
And my Arduino version is 1.8.13

The macos is connected to network via RJ45 wired ethernet, ip is 192.168.1.139, and the arduino ethernet shield is connected to the same switch with the macos.

Thanks,

I think the communication between the nano every and the ethernet shield has not been established correctly.
Using the echoserver from the file-> example->uipethernet
I got

UIPEthernetClass::tick() ERROR:EREVID=0 -> Not found ENC28j60 device !! Function ended !!

I wasn't able to find the exact schematic of my shield, so I am referring to this https://robotdyn.com/pub/media/0G-00004976==NanoEthENC28J60-Shield/DOCS/PINOUT==0G-00004976==NanoEthENC28J60-Shield.pdf

I try to look at the SPI pin from a scope on the
13, 12, 11, 10 and don't see anything activity there.

Then I look at the source

The only two place have MEGA are line 77 and 207, I haven't figure out how am I suppose to get the right pin in.

I try to add Ethernet.init(10) there and in front of the Ethernet.begin
and still got nothing.

Also reference to

I am not sure if that got resolved or not, but I haven't got it work yet.