Nano RP2040 communications with WiFi module failed

Opps, I hosed the firmware in the NINA chip. Things were going well for a bit, blinking the RGB LED but then I loaded the WiFiNINA firmware check, which said:
Firmware version installed :1.4.5
Latest firmware version available: 1.4.7

I tried the WiFi101 / WiFiNINA Firmware Updater but there was no 1.4.7 in the dropdown menu. Clicked on update to 1.4.5 thinking that would not change anything, got many errors (not recorded, sorry), and now when I run the firmware check program, it always says: Communication with WiFi module failed.

When I try to load the previous simple program to blink the RGB, no errors but no response from RGB LED.

Is there a simple way to reload the firmware in the Nina W102 module (I'm assuming that is what I hosed)?

Thank you for any leads.

A simple way is to connect the device to the Arduino IoT Cloud; while setting up the device it will configure the firmware 1.4.7.
ArduinoIoTCloud

Thank you for the pointer. I tried to connect to the Arduino IoT Cloud but cannot get by the first step. My board is not recognized, just a blank screen. And if I look at third party stuff (which this board is not) there is no entry for a nano RP2040.

This board still has the DFU part working. When I mount that on my desktop with the double reset button push, there are 2 files in there:
INDEX.HTM
INFO_UF2.TXT which says:
UF2 Bootloader v2.0
Model: Raspberry Pi RP2
Board-ID: RPI-RP2

As far as i know, that is correct, and I can still upload simple sketches, just not do anything with the NINA chip.

OK, problem solved. Solution was right in front of me. With the RP2040 board selected and seen in the Port, the available WiFi101 Update Firmware under Tools did update to 1.4.5. (at least I can blink the RGB again). No other FW version available in list.

When I try to Set up an Arduino device in Arduino Iot Cloud, is still get a blank screen.

Good to hear you got the first part resolved. Regarding the connecting the device to the IoT Cloud have you:

  1. What browser are you using? Chrome or Firefox would be ideal.
  2. Disable any firewall or antivirus that could potentially block the installation
  3. Install or update your create agent. Create Agent Installation

Hopefully that helps.