Nano RP2040 Connect fails to upload

Hi All,

I have two new Connects that I cannot get to program properly. No matter what I do I get "Upload error: Error: 2 UNKNOWN: uploading error: uploading error: exit status 1".

I have installed the Mbed OS Nano Boards core, v2.3.1. I have run the post_install.bat file. Windows recognizes the Connects as Nano RP2040 Connects when first plugged in and installing the USB drivers. Orange light flashes. RGB cycles. Green power LED is solid. I can select the board and port in the Tools menu. The board information works and returns the BN, VID, and PID. I have tried using IDE v1.8, IDE 2.0, and online editor. All fail on upload with the same error (compiles, starts upload, get the USB Windows disconnect/reconnect sound, .............. fail.).

I am out of ideas. Any suggestions on what I am missing?

Thanks!

Edit: Double pressing the reset button causes the orange led to stay solid and the RGB goes dark. The USB disconnects and reconnects but I have noticed that the IDE loses the board and Windows devices no longer recognizes the Connect (it is listed as Unknown USB Device). Pressing reset once returns to default operation and Windows recognizes the Connect again.

Edit1.5: Windows recognized the Connect briefly after double pressing the reset button again. The orange LED flickered and then went dark. A new File Explorer window popped up and I could see the 2 files. I was able to flash the Multipleblinks example. The Serial Monitor would not work though as the boards continuously cycled between being connected and disconnected. A second attempt to double press the reset button has resulted in the previous failure to connect. ???

Edit2: Shorting REC to GND and then powering the board leaves the green power led solid and all other leds off. The board is not recognized by the IDE or Windows.

Edit3: Everything seems to work using a Raspberry Pi 4 instead of PC/Windows10. See below.

The board not having a port after doing this is normal and expected. After doing that, please try an upload even though there is no port. The upload tool is able to work even without one. When you upload an Arduino sketch, it also uploads the USB stack that creates the CDC serial port and so after that first sketch upload you'll start seeing the port for the board again.

Unfortunately, that did not work.

Compilation complete.
Skipping 1200-bps touch reset: no serial port selected!
"E:\Users\Che\AppData\Local\Arduino15\packages\arduino\tools\rp2040tools\1.0.2/rp2040load" -v -D "E:\Users\Che\AppData\Local\Temp\arduino-sketch-F3C3CEE077AA34B73AF6A2288BAA98CE/MultipleBlinks.ino.elf"
rp2040load 1.0.1 - compiled with go1.15.8
.....................
Upload error: Error: 2 UNKNOWN: uploading error: uploading error: exit status 1

It also never opened as a mass storage device as well.

I noticed this warning: "WARNING: library Scheduler claims to run on mbed architecture(s) and may be incompatible with your current board which runs on mbed_nano architecture(s)." during compile. Is that a problem maybe?

Thanks!

I have installed the requisites on a Raspberry Pi 4 and have successfully uploaded code to the Nano RP2040 Connect using the RPi. This confirms that all the hardware and most the software is in operating order. Well, everything except my PC and Windows 10.

Any ideas what my issue with Windows 10 is?