Nano RP2040 Connect not showing as a device under ports

Hi,
would you please also share the code of the factory blink?
I'm totally new to this and would like to have a look at the code also.
Thank you in advance!

Sure!


#include <WiFiNINA.h>

void setup() {
  pinMode(LED_BUILTIN, OUTPUT);
  pinMode(LEDG, OUTPUT);
  pinMode(LEDB, OUTPUT);
  pinMode(LEDR, OUTPUT);
}

int ledState = LOW;
int rgb = 0;

unsigned long previousMillis = 0, interval = 1000;

void loop() {
  unsigned long currentMillis = millis();
  if (currentMillis - previousMillis >= interval) {
    previousMillis = currentMillis;

    rgb += 1;
    if (rgb == 3) {
      rgb = 0;
    }

    if (ledState == LOW) {
      ledState = HIGH;
    } else {
      ledState = LOW;
    }
  }

  digitalWrite(LED_BUILTIN, ledState);

  switch (rgb) {
    default:
      digitalWrite(LEDR, LOW);
      digitalWrite(LEDG, HIGH);
      digitalWrite(LEDB, HIGH);
      break;
    case 1:
      digitalWrite(LEDR, HIGH);
      digitalWrite(LEDG, LOW);
      digitalWrite(LEDB, HIGH);
      break;

    case 2:
      digitalWrite(LEDR, HIGH);
      digitalWrite(LEDG, HIGH);
      digitalWrite(LEDB, LOW);
      break;
  }
}

3 Likes

Thank you very much!

public service announcement arduino rp2040 cant be used with micropython. pi pico, sparkfuns and adafruits can.

your trapped in the land of slow spi. its still 16 mhz max speed. it so sad. adafruit pretending their spi speeds mean anything for rp2040 boards. its slower that due

Please can you dra a circle around the Pin :slight_smile:

@michaeljohannes this one:
a87e8746c9dbc430aeedd6d42c83c95c934d8e18

1 Like

:smiley:Steps I did to get it run again!

  1. Disconnect the NANO RP2040 from USB
  2. Ground the REC- Pin
  3. Connect the NANO RP2040 to USB
  4. Mounted RPI-RP2-folder is available on file tool
  5. Disconnect the REC-Pin from GND while powered from USB! (Without this step my Mac said something went wrong for copy step No.6)
  6. Copy the Blink.ino.elf.uf2 - file to RPI-RP2-folder
  7. Disconnect the NANO RP2040 from USB and connect it again
  8. From Now it works again!

THX!

2 Likes

I'm also on Mac and that step is crucial, it would not work for me without doing this, and I tried all sorts, it should go into the official documentation @a_guadalupi

1 Like

Hi @a_guadalupi, when I got my Nano RP2040, it got detected as COM15. Then I was trying to upload a sketch:

// the setup function runs once when you press reset or power the board
void setup() {
  // initialize digital pin LED_BUILTIN as an output.
  pinMode(LED_BUILTIN, OUTPUT);
}

// the loop function runs over and over again forever
void loop() {
  digitalWrite(LED_BUILTIN, HIGH);   // turn the LED on (HIGH is the voltage level)
  delay(50);                       // wait for a second
  digitalWrite(LED_BUILTIN, LOW);    // turn the LED off by making the voltage LOW
  delay(50);                       // wait for a second
}

after which the COM15 as well as RPI-RP2 mass storage disappeared. Then I followed the reset method mentioned above. The reset works fine and the RPI-RP2 mass storage does show up, but COM port is still not showing up. Also, when I try to copy the uf2 file to the same (or if I press the RESET button), it disappears and have to do the REC-GND reset process over again. So, the uf2 upload is also not working!
What should I do to get the COM port working? Please help me fix it.

1 Like

Hello from India!

I received two Arduino Nano RP2040 Connect boards today. But the excitement didn't last long. As soon as I tried uploading the example Blink sketch, the boards become unusable.

I tried grounding the pins and copying Blink.ino.elf.uf2 through the mass storage. Nothing happens except the green, power LED lights up.

Please help me recover the boards. I need to start working on a project immediately.

Thanks,
Janakiram

Hey @bennythebomb did you face anything like this? I'm stuck. With no COM port or code upload working!

Hi @michaeljohannes for me , during step 7, the Nano RP2040 disconnects itself. Reconnecting it again goes to a non-responsive state and have to redo the REC-GND reset for RPI-PR2 folder to show up again (as mentioned here)! Any idea why?

Folks,

Here is an update - I made the boards work by upgrading to Arduino IDE 2.0 Beta. Follow the steps @michaeljohannes shared with Arduino IDE 2.0 Beta and everything works like a charm.

1 Like

Hi @janakiramm I tried the same (with IDE version 1.8.15 as well as 2.0 beta) but step 6 closes the mounted flash folder and reconnecting doesn't open it. I have to do the reset process (REC-GND shorting) again for it to show up, but still the COM port is not showing at all! Had to do a blind reupload of a sketch as mentioned here.

1 Like

For the benefit of people who don't find the COM port listed in the device manager (for Windows; for Linux, missing from /dev/tty) or the IDE (in Tools -> Port) post-reset (REC-GND short reset for forcing ROM bootloader) - don't bother. Just do a blind upload of any sketch (eg. Examples -> 01. Basics -> BareMinimum). The COM port should reappear. Then, you can switch between serial and the flash using the RESET button (double press RESET for switching to flash and single press RESET to switch back to serial).

3 Likes

I am also facing same problem does anyone has any solution?

Thank you!
I also face the same problem others mentioned and used the REC pin shorting to ground before connecting the board to the USB port > Removed the jumper > Using Arduino IDE 2.0 Beta "blind downloaded" bare minimum as suggested by skrowten-hermit. This worked and the port re-appeared.
Same method using Arduino IDE 1.8.16 did not work

1 Like

Hi. Same problem here; The jumper wire between REC and GROUND did not work for me, neither going with arduino IDE 2.0
Only thing that worked to recover my board was to plug it while holding the button pressed. The COM port reappeared consecutively to that.
Then I uploaded the Blink basic example.

I had this problem on linux and fixed it by running the ./post_install.sh in ~/.arduino15/packages/arduino/hardware/mbed_nano/2.3.1/ after having failed uploads even after dragging in the factory elf file and resetting

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.