Nano RP2040 Driver not able to load

My computer does recognize the NANO RP2040 Connect, but will not assign a port address.

I have a Dell XPS8500 with Windows 8.1. The computer does recognize the NANO RP2040 Connect. Board. Under the computer “Device Manager”, the name “Nano RP2040 Connect” is displayed under “Other devices”, with a yellow triangle and “!”. After opening the “Nano RP2040 Connect Properties” and under “Devices status”, one of the lines reads “The drivers for this device are not installed (code28)”. Then I tried to install the driver, but I do not know the divers’ name and could not find any information on the internet or Ardino.cc. I did find the driver word “arduino.inf” under “Install the board drivers of “Getting Started with Arduino UNO | Arduino”, but no NANO RP2040 CONNECT driver.

I also installed the IDE 1.8.15 twice to verify that the IDE was installed correctly. I installed all libraries that had “rp2040” in it. I have the “Arduino Nano RP2040 Connect” checked under “board” / “Tools”.
The “Port” is greyed out and nothing happen when you click on it. The above problem still exist. I also tried to install the driver using “Update Driver” button under “Nano RP2040 Connect Properties” window. I used both the “Search Automatically …..” and “Browse my Computer……” buttons, but still no driver was loaded. I even change the location of the driver search to the “drivers” directory under Arduino directory, but still no port address. My NANO BOARD, NANO EVERY, and Arduino UNO work fine.

I’m at a loss as what to do! I would be very grateful if anybody could help me?

Hi @Randy2020. Please try uploading a sketch to your board. That will also flash the USB CDC code that creates the serial port.

When I tried to upload a basic sketch, I receive the following displayed statement, “An error occurred while uploading the sketch”. I do believe that the Window driver certification process is the problem.
If I knew the name and location of the Nano RP2040 connect driver, I could manually bypass the windows certification process. Then, I could load the driver into my computer. Do you think you can help me find the driver to load? Thank you

The driver is here:

It should have been automatically installed during the installation of the "Arduino Mbed OS Nano" boards platform you did via Boards Manager. But there is a Windows Defender confirmation dialog that must be approved for the batch file to run.

The drivers are also on your computer, most likely here:

C:\Users\<user name>\AppData\Local\Arduino15\packages\arduino\hardware\mbed_nano\2.2.0\drivers

The batch file here:

C:\Users\<user name>\AppData\Local\Arduino15\packages\arduino\hardware\mbed_nano\2.2.0\post_install.bat

Hello,

Sorry I have not emailed you to update my attempt to resolve the issue of the IDE not assigning a port address. First of all, I have been out of town all last week. Monday, July 12, after your last email, I attempted to locate the “the batch file” on my computer that you provided. I could not find anything close to the location of the driver that you supplied me. I did manually load a driver from a website that you supplied, but it also did not work. I really appreciate you trying to help me. I have come to the conclusion that Arduino RP2040 Connect will not work with my computer with Windows 8.1! The problem is one, part, or all of the following:

The user (me)

The Dell Computer

Windows 8.1

IDE 1.8.15

Arduino RP2040 CONNECT board

Thank you again, I would not recommend using Arduino RP2040 CONNECT with any Windows 8.1 Computer system.

It should be here:

C:\Users\<user name>\AppData\Local\Arduino15\packages\arduino\hardware\mbed_nano\2.3.1\post_install.bat

(the "2.3.1" part of the path is the version of Arduino Mbed OS Nano boards platform you have installed, so if you have an outdated version installed, then that part of the path will be different)

C:\Users\<user name>\AppData is hidden in Windows File Explorer by default, so you have to enable View > Hidden items before you can see that folder.

Arduino Team,

I did find the Hidden file “Post_install.bat” and executed it. Then I located the “Nano RP2040 Connect” under “Universal Serial Bus devices” within the “Device Manager”. I check for the driver in the “Nano RP2040 Connect Properties” window, looking under the “Driver” tab and found the following information:

Driver Provider: Arduino

Driver Date: 3/16/2021

Driver Version: 10.48.0.0

Digital Signer: Arduino SA

So, I assumed the driver was installed correctly. I then opened the IDE 1.8.15 and checked for the port address and no port address. Then uploaded a basic sketch and then received the uploading error message. I tried to correct the situation by using the many “trail-and-error” approach with no success.

Thank you

I'm glad to hear you were able to install the driver.

Please try this procedure now:

Hello Arduino Team,

As per your recommended “procedure”, I processed to follow “Nano RP2040 Connect technical reference | Arduino Documentation”. After opening “NanoRP2040 Connect technical reference”. I read down to “You can also visit the documentation platform for the Nano RP2040 Connect” and decided to click on “documentation platform for the Nano RP2040 Connect”. Under the title document “Nano RP2040 Connect” I click on “QUICKSTART GUIDE ” which took me to a page titled “Quickstart Guide” then I click on “Arduino IDE 1.8” and click on “NEXT”. This next page is titled “Installing Mbed OS Nano boars”, I then followed the line by line instructions (which I deleted from my computer IDE and installed IDE 1.8.15 again). Everything was going very well until I reached the section titled “Selecting the port”. The IDE would not display a port address , the Nano Rp2040 Connect was connected to the computer and the driver showed as being installed. All the other Arduino boards I have are working great!

I just do not know what I am doing wrong!

This is normal and expected after following the instructions I linked to. Please just try uploading a sketch now. Once you have successfully uploaded a sketch, you will then see a port for the Nano RP2040 Connect board.

Hello Arduino Team,

I failed to mention that I did try uploading the sketch “Blink” and the following was displayed at the bottom:

Sketch uses 79324 bytes (0%) of program storage space. Maximum is 16777216 bytes.

Global variable use 53324 bytes (19%) of dynamic memory, leaving 217012 bytes for local variables.

Maximum is 270336 bytes.

…………………

An error occurred while uploading the sketch

Then I checked to see if it had a port address and it did not. Then I checked to verify that the driver was attached to Nano RP2040 Connect by looking under “Device Manager” of my computer and it was. Sorry I did not give you more detailed information.

Hello Arduino Team,

Since I did not receive a response from you regarding my last email. I came to the conclusion that if the experts could not resolve my issue, then how in the world could I.

I came pretty close to throwing away both of my Arduino RP2040 Connect boards. Because, after my Wife came into my office (man cave) and sense I was very upset and she wanted to know why. I told her I just threw away these boards, pointing to the trash can. She picked up both boards from the trash can and put them back on my desk and at the same time saying “When you were working and having problems. You never gave up and you always found a solution, one way or another!”. Then she walked out of my office.

I said to myself, I will give it one more shot! And thinking to myself I’m a retired Mechanical Engineer, not Software Engineer or Electrical Engineer. That “one more shot” lasted 5 days and many Youtube and internet searches. Some were Computer system related and others were IDE. Such as how to “Use the command line and Task Manager to check the ports”, but the one that helped, I found today, was titled “Nano RP2040 Connect not being detected on USB port”. I followed the steps under the sub-title “Try the bootloader mode”. It WORK!!. I was able to load the “Blink” Sketch” and “Fade” Sketch which both worked great. The only problem is, the “Port” still will not display the port address. The following is the procedure to load a new Sketch:

Plug in the computer USB wire from the computer to the USB plug of the Arduino Nano RP2040 Connect.

Tap the reset button on the Nano RP2040 Connect board twice.

Download the Sketch.

Tap the reset button on the Nano RP2040 Connect board once.

The following is displayed at the bottom after the Sketch is loaded:

Sketch uses 83140 bytes (0%) of program storage space. Maximum is 16777216 bytes.

Global variables use 56496 bytes (20%) of dynamic memory, leaving 213840 bytes for local variables maximum.

.

↑what does the “orange dot'' mean?? The above procedure has to be done anytime a Sketch is downloaded and a “Port” address is NEVER displayed. WHY??

I’m happy the above procedure works, but…!

The dots are a progress indicator of the upload process, to show that something is happening. With a longer upload, you should see additional dots appear.

Does the behavior you describe happen even after you upload the File > New sketch?

Hello Arduino Team,

Thank you for the quick response. The first part of you last email stated:

The dots are progress indicator of the upload process, to show that something is happening. With a longer upload, you should see additional dots appear.

In my experience with the dots, they only are displayed below the sketch when there is a problem with uploading the sketch to the boards. I do not believe the dots have anything to do with how large the sketch is or the length of time it takes to upload. For example, I wrote a sketch with 16 lines and uploaded it to my Arduino NANO BOARD (Chip: ATMEGA328 & Clock speed: 16MHz) with no dots. The board executed the uploaded sketch with no problems. The following is the only text displayed below the 16 lines sketch:

Sketch uses 982 bytes (3%) of program storage space. Maximum is 30720.

Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.

Next, I tried to upload the same above sketch to my Arduino NANO RP2040 CONNECT (without using the stated procedure under “Try the bootloader mode” in my last email) and it did not upload. The following was displayed below the 16 lines sketch:

Sketch uses 79324 bytes (0%) of program storage space. Maximum is 16777216 bytes.

Global variables use 53324 bytes (19%) of dynamic memory, leaving 217012 bytes for local variables. Maximum is 270336 bytes.

…………………

An error occurred while uploading the sketch

As you can see there are 21 dots displayed and the sketch was NOT uploaded. The NANO RP2040 CONNECT has the Chip RP2040 and Clock speed of 133MHz and it did take 24.14 seconds trying to upload before it stopped.

Then the next time, I tried and succeeded in uploading the same 16 lines sketch to the NANO RP2040 CONNECT board. This time I did use the procedure that was stated under “Try the bootloader mode” as mentioned in my last email. Below is all the text that was displayed below the same 16 lines sketch.

Sketch uses 79324 bytes (0%) of program storage space. Maximum is 16777216 bytes.

Global variables use 53324 bytes (19%) of dynamic memory, leaving 217012 bytes for local variables. Maximum is 270336 bytes.

.

AS you see there is only one dot, but the sketch did upload and NANO RP2040 CONNECT executed the uploaded sketch flawlessly. There is and always has been no port address displayed under “Port”. It took 15.76 seconds to upload this sketch. I then uploaded the largest sketch I have, which is 6606 bytes and it took 16.05 seconds to upload. This larger sketch had no dots, but it took longer to upload then the one dot sketch. Maybe my stop watch is not consistent. Forget about the dots, the no port address is still not displayed.

To address your question about using the File > New. I did the above sketch using the New command under the File header and received the same results, no Port address.

This was the first step I did without using the above “procedure”.

Is there anything else that can be looked at?

You are right. I apologize for any confusion my erroneous statement might have caused, The dots are an indicator of each attempt. In general, a successful upload only takes a single attempt, so you get a single dot. If the upload can't start then the tool retries and prints a dot each time.

If you turn on "Verbose output during: upload" in the Arduino IDE's File > Preferences, then you will see a nice upload progress indicator:

Loading into Flash: [==============================]  100%

This only appears once the tool has been able to start an upload.

Hello Arduino Team,

Per your recommendation, I did check the “upload” box under “Verbose output during:” I then uploaded the 16 lines sketch using the “procedure” that I have stated previously. The following was displayed under the 16 lines sketch:

Sketch uses 79412 bytes (0%) of program storage space. Maximum is 16777216 bytes.

Global variables use 53340 bytes (19%) of dynamic memory, leaving 216996 bytes for local variables. Maximum is 270336 bytes.

C:\Users<user name>\AppData\Local\Arduino15\packages\arduino\rp2040tools\1.0.2/rp2040 –v –D

C:\Users<user name>\AppData\Local\Temp\arduino_build_198789/7_24_2021_Yellow_and_Red_LED_.5_second_Blink.ino.elf

Rp2040load 1.0.1 – compiled with go1.15.8

Loading into Flash: [==============================] 100%

I do not know what the above indicates, do you? Does the above help in any way to solve the issue of not having the “Port” address displayed?

Below is the summary of stated issues and solutions as of July 25,2021:

ISSUES:

1: The Arduino NANO RP2040 CONNECT does not display a “Port” address in the IDE.

2: The Arduino NANO RP2040 CONNECT will not accept a sketch from the IDE 1.8.15.

SOLUTIONS:

Issue 1: Has not been resolved as of July 25, 2021.

Issue 2: Without a “port” address, the only solution is to use the procedure as outlined in the paper title “Nano RP2040 Connect not being detected on USB port” under the sub-title “Try the bootloader mode”.

In my opinion, the only solution to the above issues is to have a Software Engineer with expertise in Arduino IDE and Windows 8.1 to give a compendious study for analysis and solution recommendation(s).