Nano rp2040 works only via bootloader mode

Hi Guys,
I bought the new Nano RP2040 Connect board and I had a lot of problems with drivers, in few words I followed any official guide to install the specific driver but the board is still not well recognized (on device manager I have the label "Nano RP2040 Connect" with the yellow exclamation mark and no driver associated). Indeed if i try to upload I always get the below general Error for sketch uploading:

"
rp2040load 1.0.1 - compiled with go1.15.8
.....................
Errore durante il caricamento dello sketch
"

So following the guide at "Nano RP2040 Connect not being detected on USB port – Arduino Help Center"
I found the workaround to upload the sketches, if I activate the BOOTLOADER MODE every upload goes fine, but if I would like to use the cloud service I am not able since the board is not recognized again... Did you have any suggestion ?
How is possible I have to work in Bootloader mode and not as standard way ? I tried with different windows version but the problem persists.
Thanks a lot.