Nano stopped communicating on serial port...no upload now

I am using Windows 8.1 and successfully turned on and programmed a Nano yesterday. I declared victory by loading the routine that causes the LED to blink on and off for a second each time. Then, I copied the Blink program, changed the delay times to 3000 ms (instead of 1000 ms), uploaded again and sure enough, the LED was blinking 3 seconds on and 3 seconds off.

I have been very careful with the board regarding ESD and general protection both electrically and mechanically but today, for some reason, I cannot upload to the board. I get the following error message:

"Arduino: 1.6.3 (Windows 8.1), Board: "Arduino Nano, ATmega328"

Sketch uses 1,030 bytes (3%) of program storage space. Maximum is 30,720 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.
avrdude: ser_open(): can't open device "\.\COM1": Access is denied. "

I have tried assigning different numbers to the COM port and have tried different USB ports in my computer.

Any suggestions?

Thank you.

Are you sure you selected the right serial port?