Nano stopped uploading (after running large code?)

My uploads were fine until I added a lot of serial prints. After I uploaded the extra prints, I saw a few of them on the serial monitor, followed by a bunch of corrupt text (stack overflow?)

Now, when I attempt to upload (control u), I get "protocol error expect=0x14, resp=0xa".

I switched to uploading blink to rule out a problem with code size.

My device manager still shows my "ch340 nano device" under the "lpt com" settings.

I can still upload with a isp upload (control shift u) using another as an Arduino programmer.

I tried reloading the bootloader, but I still can't program my nano with the usb port. I tried another computer.

I saw the method of continuously pressing reset, and uploading, http://forum.arduino.cc/index.php?topic=428517.msg2953702#msg2953702, but I tried and get the same protocol error.

Should my isp programming , and my re-burning the bootloader, suffice for getting my nano back to it's original state?

You should be aware that when you do Ctrl + Shift + U you overwrite the bootloader so you always need to do a Tools > Bootloader again after doing that to replace the bootloader before you can start uploading via USB again.