Nano v3.0 start up...

Hi,

I'm getting stuck at the set up point with my new Nano. I only have bluetooth options listed in my serial port config menu (I'm running Arduino 16 on a Macbook) and not any option to use the usb cable I have. The only options are:

  • /dev/tty.Bluetooth-PDA-Sync
  • /dev/cu.Bluetooth-PDA-Sync
  • /dev/ttv.Bluetooth-Modem
  • /dev/cu.Bluetooth-Modem

Any ideas why I can't see any usb options?

Cheers,

Adbo

On Linux I just needed to activate the "USB FTDI Single Port Serial Driver" which creates /dev/ttyUSB0.

It should be simalar on Mac, the only difference is that on Mac the kernel has not included this by default. You have to install it manually I guess (without being a Mac expert).

You can download drivers for Mac from
http://www.ftdichip.com/FTDrivers.htm

Thanks for that...I'll give it a go.

Adbo

can you let me know if this worked? I just ordered a nano 3.0 and I am using a mac.

You bet...I plan to try it tonight. I installed the D2XX FTDI drivers from the link posted above; USB still isn't showing up in the serial port menu but that may be because I don't have the board plugged in right now...I'll update tonight.

Adbo

You want the virtual com port drivers, not the D2XX ones.

ok good info. Thanks for that. I will install those. Should I remove the D2XX drivers?

Ok well I installed the virtual port drivers and still no love. The list in the Serial Port menu hasn't changed. I know that I can edit the preferences.txt file but I don't know what the correct words would be for the serial.port entry.

The board seems fine thankfully....just wish I could interact with it.

Any ideas?

Best,
Adbo

ok well I tried a bunch of stuff including frolicking through the user docs and found these two entries in the pdf:

Problem:The device does not appear in the /dev directory or the text “New
Port Detected” is not displayed in SystemPreferences-Network

Sol’n: FTDIUSBSerialDriver does not support your deviceID (VID and PID). Disable the EEPROM so that
the device reverts to its default deviceID, then replug.
To get support for your deviceID built into FTDIUSBSerialDriver, contact FTDI quoting your
deviceID and a description of your device.

** I don’t think this is the problem since it’s an arduino board

Problem: The device cannot be accessed even though the deviceID is
supported in FTDIUSBSerialDriver

Sol’n: An ownership or permissions problem is preventing the system from making the device accessible.
Check that the driver is owned by root and wheel. The most common symptom is the group for
FTDIUSBSerialDriver is not wheel. To change the group, login as root and perform the following
script in a Terminal window (Go > Applications > Utilities > Terminal):
cd /system/library/extensions
chgrp -R wheel FTDIUSBSerialDriver.kext
Reboot for the change to take effect.

** I suspected this should be the prob. but this sol’n didn’t seem to help.

When I browse the /dev dir I’m not seeing the expected tty.usbserial or cu.usbserial entries so I’m not really sure what to do next.

Any one have any thoughts?

Cheers again,
Adbo

ok all appears to be well. Here's what I did (white macbook version).

  • download Arduino 17
  • Install the Intel Mac FTDI drivers included in the .dmg
  • Install the Arduino IDE
  • Plugged in the Nano via USB (I used the port furthest from the screen; I understand that port has better current behaviour)
  • Restarted Arduino 17 w/ the Nano plugged in (not sure if that makes a difference)

The tty.usbserial and cu.usbserial are now in the serial port menu.

Thanks for the help mellis et. al. Pir800: Let me know how it goes

Best,
Adbo

Final verification: just ran the blink example code and it works!

Adbo