nano v3 clone refuses to program

I've got a nano v3 clone that I can't seem to program. The things I've tried:

  • connected the nano directly, error unexpected response.
  • installed the ch340 usb to rs232 chip drivers, no problems, com port is assigned.
  • burn bootloader using arduino mega 2560, pins 50..53, triple checked connections
  • followed a tutorial that mentioned to place a capacitor between reset and 5v on mega 2560
  • tried 3 different usb leads including a very short one. I've successfully used it to program pic micros using pickit3
  • I've tried to program the sketch using the mega as isp by programming it as isp, choosing the nano, arduino as isp and burn bootloader.
  • resoldered the chip pins
  • the nano power led lights up, rx and L blink randomly sometimes.
  • tried arduino studio v 1.0.1, 1.0.6, 1.6.x.
  • checked connection from icsp header to chip pins, all correct.

Is there anything else I can try?

I've ordered a nano v3 based on ftdi chip, hopefully I have better luck with that. If it really is a doa, I'll convert it to a rs232 adapter.

I didn't see if you mentioned what OS you are running (LINUX?)

If you have a "serial dongle to usb", that may do the trick if it is based on the Ft232R. IF not, may consider ordering one for just such an occasion. Mine has been useful.

I ordered some nanos from china that said they were FT232R, but when they got here they were CN340G. They may send you other than what you request FYI.

I am using the chromebook, so I have limited resources as opposed to other OS.

Thanks for the quick reply! I'm using windows 7.

I have a couple of other brands of rs232 dongles, not ftdi or ch340 which do work on their own, I managed to communicate with a pic microcontroller but it doesn't break out any control signals unfortunately. But you'd need a bootloader in place before it works anyway, I'm not sure exactly what you mean by that.

I've now ordered locally and it was clearly stating it was ftdi. The board looks more like the arduino original too.

what is the error you are getting :-
go to arduino IDE , files , preferences set the verbose output for upload on , and show what it tells ?
also get the correct ch340 drivers !
here are the ones i used with my clone :-
the file is uploaded by me and hosted by mediafire :
this is the correct driver ! and yeah its in chinese , but its basically easy to install it !
first make sure you uninstall the old drivers !

the link is :- CH341SER

just extract the two folders , go to CH341SER folder , then go to install , then do it !