nano v3 - no serial port on Ubuntu 12.04- works ok in Ubuntu 10.04

Hello, On Ubuntu 12.04 the serial port is greyed out when plugging in Nano v3. If I plug in a Uno this works fine and serial port (ttyACM0) is selectable.

The really odd thing is that if i plug the same Nano into my Ubuntu 10.04 setup the serial port selection is available (ttyUSB0) and on plugging in the same Uno a serial port for that is available too (ttyACM0). So my question is, as the Arduino boards are the same ones in each setup, why do they work ok in 10.04 but not the Nano in 12.04. I've tried both IDE 1.0 and 1.0.3 and get the same problem On another note I have a similar issue in Windows 7. the Uno works fine but I am not able to install the driver for the FTDI so that the Nano can been seen. I've gone round in circles but I always end up with an error code 10 - can't start device. If I can solve the problem in Ubuntu 12.04 I'm not too fussed about getting it to work in Win7. Any help or pointers would be appreciated.

Well well. Sorted it out. Very odd as it was the usb cable. Works on one machine but not on the other - Go figure! As soon as I change the usb cable Ubuntu 12.04 was ok and in Windows 7 the nano driver installed no problem. I read reams of stuff on the net where people were having problems installing the driver in Win 7 for Nano, in many cases it could just be the cable. I was thrown off the scent as the Nano worked perfect in Ubuntu 10.04. Hope this helps someone.