NanoESP hat einen Fehler angezeigt

Ich habe ein Problem
Ich habe einen Adventskalender von Conrad bekommen und habe eine Frage
Bei mir auf der Platte also den NanoESP ist was umgestellt hier dagestellt:

Warnung: platform.txt aus dem Kern 'Arduino AVR Boards' enthält veraltete recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{build.path}/{archive_file}" "{object_file}" und wurde automatisch zu recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{archive_file_path}" "{object_file}" konvertiert. Erwägen Sie eine Aktualisierung dieses Kerns.
WARNUNG: Kategorie '' in der Bibliothek EEPROM ist ungültig und wird auf 'Uncategorized' festgelegt
WARNUNG: Kategorie '' in der Bibliothek SPI ist ungültig und wird auf 'Uncategorized' festgelegt
WARNUNG: Kategorie '' in der Bibliothek SoftwareSerial ist ungültig und wird auf 'Uncategorized' festgelegt
WARNUNG: Kategorie '' in der Bibliothek Wire ist ungültig und wird auf 'Uncategorized' festgelegt

Ich hoffe ihr könnt mir helfen das wehre nett.
Freue mich auf jede antwort.

Euer JOMIDETV

Welchen Adventskalender?
Ohne mehr Info ist es schwer Dir zu helfen.
Grüße Uwe

JomideTV:
Ich habe ein Problem
Ich habe einen Adventskalender von Conrad bekommen und habe eine Frage
Bei mir auf der Platte also den NanoESP ist was umgestellt hier dagestellt:

Warnung: platform.txt aus dem Kern ‘Arduino AVR Boards’ enthält veraltete recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} “{build.path}/{archive_file}” “{object_file}” und wurde automatisch zu recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} “{archive_file_path}” “{object_file}” konvertiert. Erwägen Sie eine Aktualisierung dieses Kerns.
WARNUNG: Kategorie ‘’ in der Bibliothek EEPROM ist ungültig und wird auf ‘Uncategorized’ festgelegt
WARNUNG: Kategorie ‘’ in der Bibliothek SPI ist ungültig und wird auf ‘Uncategorized’ festgelegt
WARNUNG: Kategorie ‘’ in der Bibliothek SoftwareSerial ist ungültig und wird auf ‘Uncategorized’ festgelegt
WARNUNG: Kategorie ‘’ in der Bibliothek Wire ist ungültig und wird auf ‘Uncategorized’ festgelegt

Ich hoffe ihr könnt mir helfen das wehre nett.
Freue mich auf jede antwort.

Euer JOMIDETV

Sorry, aber das kann keiner verstehen.

uwefed:
Welchen Adventskalender?

Es scheint sich um diesen ausverkauften "Internet of Things" Adventskalender zu handeln.

Dabei handelt es sich im wesentlichen um ein

  • Arduino Nano kompatibles Board
  • das direkt onboard seriell mit einem ESP8266 Modul mit AT-Firmware verheirated worden zu sein scheint

Also im Prinzip ein "Arduino Nano" kompatibles Board, das ein ESP8266 mit AT-Befehlen seriell ansteuern kann, fix und fertig verdrahtet auf einer gemeinsamen Platine.

Die "Anleitung zum Adventskalender" im PDF-Format ist bei Conrad downloadbar.

Und dort steht drin:

Ich habe mit den Arduino™-Versionen 1.6.4 – 1.6.5 gearbeitet.
Ältere Versionen können Probleme verursachen.
Für manche Linux-Versionen existiert derzeit allerdings nur eine sehr alte Version.

Also wer Windows hat, sollte eine relativ aktuelle Arduino IDE zwischen 1.6.4 und 1.6.5 installieren.

Und wer Linux als Betriebssystem hat, der ist in den Arsch gekniffen, wenn er die falsche Linux-Distribution installiert hat, für die es keine aktuelle Arduino-IDE gibt, sondern auf seiner Linux Exoten-Distri nur irgendwelche uralten Arduinoversionen laufen, aber nix aktuelles.

@jurs
Dann hoffe ich nur, dass der TO das auch liest und versteht.

jurs:
Und wer Linux als Betriebssystem hat, der ist in den Arsch gekniffen, wenn er die falsche Linux-Distribution installiert hat, für die es keine aktuelle Arduino-IDE gibt, sondern auf seiner Linux Exoten-Distri nur irgendwelche uralten Arduinoversionen laufen, aber nix aktuelles.

Was hat die Linux Distro mit der Arduino Version zu tun? Die ganzen Versionen sind genauso wie auf Windows auch erschienen. :neutral_face:

uwefed:
Welchen Adventskalender?
Ohne mehr Info ist es schwer Dir zu helfen.
Grüße Uwe

Was möchtest du denn gerne wissen?

Hallo,

ich würde mal versuchen genau die empfohlene Arduino IDE Version 1.6.4 oder 1.6.5 zu verwenden, nicht etwa die neuere 1.6.6. Oft genug zwickt eine bstimte Library nicht nur mit einer zu alten sondern auch mit einer zu neuen Version.

Christian

Hi,
ich glaube die Fehlerbeschreibung hilft nicht viel. Kannst du gar keine Programme aufspielen? Kompilieren die Programme nicht? Ist das Board richtig installiert?

Es gibt übrigens auch eine Support-Seite zu dem Adventskalender und dem Board:
www.iot.fkainka.de

Ich befürchte, der TO versteht uns nicht.

Hi zusammen,

ich habe das gleiche Problem allerdings ganz simpel mit der neusten IDE 1.6.10 siehe unten.
In den jeweiligen library.properties welche in jedem Verzeichnis liegt, steht überall eine Kategorie drin, auch Kategorien die es so bereits gibt, also keine ausgedachten.

Weiter kommt der Fehler schon beim Kompilieren also beim Überprüfen Button. Ich schliesse daher die Hardware und ein damit verbundenes Problem aus.

Kann jemand von euch weiterhelfen?

anbei die Fehlermeldung,

danke und Grüße

Dave

Arduino: 1.6.10 (Windows 7), Board: "Arduino Nano, ATmega328"

WARNUNG: Kategorie '' in der Bibliothek Audio ist ungültig und wird auf 'Uncategorized' festgelegt
WARNUNG: Kategorie '' in der Bibliothek Scheduler ist ungültig und wird auf 'Uncategorized' festgelegt
WARNUNG: Kategorie '' in der Bibliothek UIPEthernet ist ungültig und wird auf 'Uncategorized' festgelegt
WARNUNG: Kategorie '' in der Bibliothek USBHost ist ungültig und wird auf 'Uncategorized' festgelegt
WARNUNG: Kategorie '' in der Bibliothek EEPROM ist ungültig und wird auf 'Uncategorized' festgelegt
WARNUNG: Kategorie '' in der Bibliothek SPI ist ungültig und wird auf 'Uncategorized' festgelegt
WARNUNG: Kategorie '' in der Bibliothek SoftwareSerial ist ungültig und wird auf 'Uncategorized' festgelegt
WARNUNG: Kategorie '' in der Bibliothek Wire ist ungültig und wird auf 'Uncategorized' festgelegt
Warnung: platform.txt aus dem Kern 'Arduino AVR Boards' enthält veraltete recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{build.path}/{archive_file}" "{object_file}" und wurde automatisch zu recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{archive_file_path}" "{object_file}" konvertiert. Erwägen Sie eine Aktualisierung dieses Kerns.
collect2.exe: fatal error: cannot find 'ld'

compilation terminated.

exit status 1
Fehler beim Kompilieren für das Board Arduino Nano.
Ungültige Bibliothek D:\Dave\Cloud Station\Arduino\Arduino\libraries\DI-WL in D:\Dave\Cloud Station\Arduino\Arduino\libraries\DI-WL gefunden

Dieser Bericht wäre detaillierter, wenn die Option
"Ausführliche Ausgabe während der Kompilierung"
in Datei -> Voreinstellungen aktiviert wäre.