Não consigo fazer um LCD funcionar

Boa tarde pessoal, sou novo aqui e ja venho com problemas :sweat_smile:

Tenho um LCD 16x2 e não consigo fazer ele funcionar.
Liguei tudo certinho como no exemplo do arduino mas a única coisa que aparece são quadrados na primeira linha. Inverti fios, troque de portas, mas nada funcionou.

Não sei mais o que fazer.

Obrigado

Ola bem vindo.
Qual lcd?
O HD44780?
Alteras-te o valor de contraste no potenciometro?
Como tens ligado?
Que codigo usas-te?

HugoPT:
Ola bem vindo.
Qual lcd?
O HD44780?
Alteras-te o valor de contraste no potenciometro?
Como tens ligado?
Que codigo usas-te?

Esse mesmo.
O contraste com potenciometro funciona.
Liguei exatamente como diz o exemplo que tem na IDE do arduino.

pin1 - GND
pin2 - 5v
pin3 - potenciometro
RS - 12

R/W - GND
E - 11

D0 - Nao
D1 - Nao
D2 - Nao
D3 - Nao

D4 - 2
D5 - 3
D6 - 4
D7 - 5

E o BKL

E que codigo é que fizeste upload
Coloca aqui:

/*
  LiquidCrystal Library - Hello World
 
 Demonstrates the use a 16x2 LCD display.  The LiquidCrystal
 library works with all LCD displays that are compatible with the 
 Hitachi HD44780 driver. There are many of them out there, and you
 can usually tell them by the 16-pin interface.
 
 This sketch prints "Hello World!" to the LCD
 and shows the time.
 
  The circuit:
 * LCD RS pin to digital pin 12
 * LCD Enable pin to digital pin 11
 * LCD D4 pin to digital pin 5
 * LCD D5 pin to digital pin 4
 * LCD D6 pin to digital pin 3
 * LCD D7 pin to digital pin 2
 * LCD R/W pin to ground
 * 10K resistor:
 * ends to +5V and ground
 * wiper to LCD VO pin (pin 3)
 
 Library originally added 18 Apr 2008
 by David A. Mellis
 library modified 5 Jul 2009
 by Limor Fried (http://www.ladyada.net)
 example added 9 Jul 2009
 by Tom Igoe
 modified 22 Nov 2010
 by Tom Igoe
 
 This example code is in the public domain.

 http://www.arduino.cc/en/Tutorial/LiquidCrystal
 */

// include the library code:
#include <LiquidCrystal.h>

// initialize the library with the numbers of the interface pins
LiquidCrystal lcd(12, 11, 5, 4, 3, 2);

void setup() {
  // set up the LCD's number of columns and rows: 
  lcd.begin(16, 2);
  // Print a message to the LCD.
  lcd.print("hello, world!");
}

void loop() {
  // set the cursor to column 0, line 1
  // (note: line 1 is the second row, since counting begins with 0):
  lcd.setCursor(0, 1);
  // print the number of seconds since reset:
  lcd.print(millis()/1000);
}

Tu tens:
D4 - 2
D5 - 3
D6 - 4
D7 - 5
O programa diz:

The circuit:

  • LCD RS pin to digital pin 12
  • LCD Enable pin to digital pin 11
  • LCD D4 pin to digital pin 5
  • LCD D5 pin to digital pin 4
  • LCD D6 pin to digital pin 3
  • LCD D7 pin to digital pin 2
  • LCD R/W pin to ground
  • 10K resistor:
  • ends to +5V and ground
  • wiper to LCD VO pin (pin 3)

Portanto tens os pinos ao contrario

HugoPT:
Tu tens:
D4 - 2
D5 - 3
D6 - 4
D7 - 5
O programa diz:

The circuit:

  • LCD RS pin to digital pin 12
  • LCD Enable pin to digital pin 11
  • LCD D4 pin to digital pin 5
  • LCD D5 pin to digital pin 4
  • LCD D6 pin to digital pin 3
  • LCD D7 pin to digital pin 2
  • LCD R/W pin to ground
  • 10K resistor:
  • ends to +5V and ground
  • wiper to LCD VO pin (pin 3)

Portanto tens os pinos ao contrario

Acabei me confundindo, mas está como no exemplo.

  • LCD D4 pin to digital pin 5
  • LCD D5 pin to digital pin 4
  • LCD D6 pin to digital pin 3
  • LCD D7 pin to digital pin 2

Eu estou tendo um problema que de certa maneira é relacionável com o seu, mas no meu caso, eu já fiz ele funcionar e sei que o esquema de ligação está correto.
O que me acontece é exatamente como você descreve, o que eu faço para resolver parece meio estúpido, mas funcionou algumas vezes.
Insira e retire o cabo usb umas 3-4 vezes para ver se o sketch aparece na tela, não faço a menor ideia do porque isso acontece.

fernandossala:
Eu estou tendo um problema que de certa maneira é relacionável com o seu, mas no meu caso, eu já fiz ele funcionar e sei que o esquema de ligação está correto.
O que me acontece é exatamente como você descreve, o que eu faço para resolver parece meio estúpido, mas funcionou algumas vezes.
Insira e retire o cabo usb umas 3-4 vezes para ver se o sketch aparece na tela, não faço a menor ideia do porque isso acontece.

não funcionou

testa os seus pinos com um potenciometro e o sketch do analog read, vê se os dados são consistentes.

se sim, refaça as ligações, use jumpers adequados, verifique se você está energizando a sua protoboard corretamente, confira novamente tudo 3 vezes, é fácil de se confundir com o lcd pois ele fica na frente da visão do protoboard, o que eu fiz quando estava montando foi virar a imagem do esquema de ligação de cabeça pra baixo.

consegue testar em outro arduino?
pode trocar o lcd onde comprou ou comprar outro?

fernandossala:
testa os seus pinos com um potenciometro e o sketch do analog read, vê se os dados são consistentes.

se sim, refaça as ligações, use jumpers adequados, verifique se você está energizando a sua protoboard corretamente, confira novamente tudo 3 vezes, é fácil de se confundir com o lcd pois ele fica na frente da visão do protoboard, o que eu fiz quando estava montando foi virar a imagem do esquema de ligação de cabeça pra baixo.

consegue testar em outro arduino?
pode trocar o lcd onde comprou ou comprar outro?

Tenho mais nada pra testar. O LCD está ligado corretamente

olha, vc está dizendo que fez a ligação corretamente, o sketch que tá postado aqui é igual ao da biblioteca do arduino, então aparentemente tudo o que vc fez está certo

vc não tem o pot de 10k do contraste? usa ele pra testar os pinos do arduino, você sabe se você torrou sem querer um dos pinos testando outras coisas?

tira uma foto pras pessoas verem o seu esquema de ligação, assim talvez alguém possa te ajudar, a solução não vai vir tão fácil, ainda mais se vc já desistiu.

Podes colocar uma foto do teu circuito montado??
Eu tenho varios displays desses e nunca tive algum problema em liga-lo.

fernandossala:
olha, vc está dizendo que fez a ligação corretamente, o sketch que tá postado aqui é igual ao da biblioteca do arduino, então aparentemente tudo o que vc fez está certo

vc não tem o pot de 10k do contraste? usa ele pra testar os pinos do arduino, você sabe se você torrou sem querer um dos pinos testando outras coisas?

tira uma foto pras pessoas verem o seu esquema de ligação, assim talvez alguém possa te ajudar, a solução não vai vir tão fácil, ainda mais se vc já desistiu.

Não entendi, testa como com o potenciometro?

Mas afinal queres ajuda ou nao?

tira uma foto pras pessoas verem o seu esquema de ligação, assim talvez alguém possa te ajudar, a solução não vai vir tão fácil, ainda mais se vc já desistiu.

Podes colocar uma foto do teu circuito montado??

Será necessário pedir mais uma vez o raio do circuito?

Não entendi, testa como com o potenciometro?

faz esse tutorial http://arduino.cc/en/Tutorial/AnalogReadSerial#.Uw92VYUyvi0

e troca no código o analogRead por digitalRead
quando o código terminar de carregar no seu arduino abre o serial monitor com ctrl shift m

aí vc testa o pino analógico A0 primeiro e vai trocando A0 por A1, A2 no seu código e mudando o fio do meio do potenciometro pros pinos testados. quando chegar nos pinos digitais que são de 2 a 13 (sendo que o 13 é do led e não precisamos testar se o led da placa funciona) você não precisa por A apenas o número do pino.

lembra que toda vez que carregar o código você abre o serial monitor para ver os valores mudando, que na verdade você vai ver apenas 0 e 1, mas é o suficiente para saber que com N de resistência ele lê como LOW e N+X de resistência no potenciômetro ele lê como HIGH.

o ideal seria usar um botão para os pinos digitais e um potenciometro para os pinos analogicos, mas isso deve servir

e faça o favor de postar uma foto do seu projeto

Acho que isto para apenas testar apenas potenciômetro e demasiado “over kill”.
Porque não apenas pegar no multímetro e verificar a variação da resistência?
O problema pode ate ser o contraste mas quer me parecer mais que será as ligações na breadboard.

HugoPT:
Acho que isto para apenas testar apenas potenciômetro e demasiado "over kill".
Porque não apenas pegar no multímetro e verificar a variação da resistência?
O problema pode ate ser o contraste mas quer me parecer mais que será as ligações na breadboard.

mas não é para testar o potenciômetro, isso ele mesmo disse que funciona, é uma maneira de ele testar os pinos do arduino

Mas ele nem sequer esta a usar o ADC, para isso não seria bem mais fácil colocar os pinos como entrada, ativar o pull up interno deles e por a escrever o seu estado na porta Serie.Depois pra testar como saída um LED em cada um dos pinos e setar o porto inteiro ou pino a pino.

tens razão, seu método é mais simples :sweat_smile:
acho que pouco importa, o OP nem se manifestou mais em relação a isso