Need help : Analog inputs and switches (after code modification) doesn't work

Hi arduino community. I'm a noob at this but I'm trying to learn with baby steps. I've found a project online in which you could control a led using a checkbox or a button and in the same time you can see the analog inputs and the switch status. Everything was working fine and this is why I wanted to take it a little further (Using an arduino mega board + ethernet shield with SD card as a webserver). I've placed in total 20 LEDs but I am to use the majority of them for different purposes such as control a motor to open or close a door or a window and using a thermo sensor (LM35) in order to open a fan when it's hot and a light sensor in order to open the lights at the garden at nightfall. Basically I'm trying to build a mini smart home and I was getting there but the analog inputs and the switch status at the page wasn't showing up at all instead it was showing "..." in the analog inputs which is the text at the html file. The arduino and the html code can be found here http://pastebin.com/Kce1QHx8 Arduino http://pastebin.com/tAJ0DM9D HTML I can provide the original code as well (The code which I modified) I'm getting the over 9000 error this is why I used pastebin for the codes. Any help would be appreciated. Thank you very much!

Please post your code in this forum.

This can be done by placing     [code]  and [/code]  around the code or use the </> icon. This makes it easier for others to read.

How to use this forum

Weedpharma

weedpharma:
Please post your code in this forum.

This can be done by placing     [code]  and [/code]  around the code or use the </> icon. This makes it easier for others to read.

How to use this forum

Weedpharma

Unless if I get the “over 9000 characters” error, then I can’t, dunno why.

Then you have two choices 1) Cut down your code so that it is a lot smaller and still shows your problem 2) Attach the code file. Use the reply box and then additional options triangle.

Also do not forget the schematic, code means little without one.

Hi,

Hi arduino community. I'm a noob at this but I'm trying to learn with baby steps. I've found a project online in which you could control a led using a checkbox or a button and in the same time you can see the analog inputs and the switch status. Everything was working fine and this is why I wanted to take it a little further. (Using an arduino mega board + ethernet shield with SD card as a webserver) I've placed in total 20 LEDs but I am to use the majority of them for different purposes.

Such as: control a motor to open or close a door or a window using a thermo sensor (LM35) in order to open a fan when it's hot light sensor in order to open the lights at the garden at nightfall.

Basically I'm trying to build a mini smart home and I was getting there but the analog inputs and the switch status at the page wasn't showing up at all instead it was showing "..." in the analog inputs which is the text at the html file. The arduino and the html code can be found here http://pastebin.com/Kce1QHx8 Arduino http://pastebin.com/tAJ0DM9D HTML

I can provide the original code as well (The code which I modified) I'm getting the over 9000 error this is why I used pastebin for the codes. Any help would be appreciated. Thank you very much!

Sorry, but putting your request in a point type form, makes it easier to understand.

Can you please post a copy of your circuit, in CAD or a picture of a hand drawn circuit in jpg, png? How are you powering your project?

Thanks.. Tom.. :)

No need anymore, I have found my mistake and it is now fixed. This thread can be closed :)

Hi, Can you go and edit the subject of this thread and ad [SOLVED] to it.

Thanks.. Tom.. :)