Need help getting a program to loop

PaulS: Resetting the message received time, without resetting index, will only half solve the problem.

well not if index is calculated based on that variable, right?As per the start of the loop()

    unsigned long elapsed = millis() - received;
    int index = elapsed/MILLIS_PER_LETTER;

seems it's the case...

well not if index is calculated based on that variable, right?

Yes, you are correct.

Robin2: @cgsmith324, did you study Reply #4?

...R

I did. I tried that. But I don't really have any knowledge of this language. Basically, the thing that would help me the most is one of y'all plugging your solution into the code, and then putting the entire code in here so I can copy and paste. I know that's probably asking too much. I'm sure a lot of these replies would fix my issue, but I have upload errors because I just don't know where to put the snippets of code y'all are giving me.

Read #17

We don’t do the coding for you here - some assembly required

cgsmith324: but I have upload errors because I just don't know where to put the snippets of code y'all are giving me.

Post the code that represents you best attempt and also the text of the error message.

It would also help if you tell us what you think the error message means as that will help us to understand how you are thinking about the problem.

On the other hand if you just want someone to write a program for you please ask in the Gigs and Collaborations section of the Forum and be prepared to pay.

...R