Need help understanding error message in Temp/Humidity with i2c LCD sketch

Hello,

I tried to run a sketch that uses a DHT11 and an I2C LCD display that was posted on Instructables. When I verified it I received errors. I can’t figure out exactly what they mean. Sometimes, on other sketches, I can figure out and correct the problem. On this one I’m stuck, bad! I’m posting the sketch and the error message below.

Thank you for any help,
Michael

//DHT11 Sensor:
#include "DHT.h"
#define DHTPIN 12     // what digital pin we're connected to
#define DHTTYPE DHT11   // DHT 11

DHT dht(DHTPIN, DHTTYPE);


//I2C LCD:
#include <Wire.h> // Comes with Arduino IDE
#include <LiquidCrystal_I2C.h>

// Set the LCD I2C address
LiquidCrystal_I2C lcd(0x27, 2, 1, 0, 4, 5, 6, 7, 3, POSITIVE); 


void setup() {
  Serial.begin(9600);
  lcd.begin(16,2);
  Serial.println("Mohamed Chaara Temp and Humidity Sensor Test");

  dht.begin();
}

void loop() {
    // Reading temperature or humidity takes about 250 milliseconds!
  // Sensor readings may also be up to 2 seconds 'old' (its a very slow sensor)
  int h = dht.readHumidity();
  int t = dht.readTemperature();

    // set the cursor to (0,0):
  lcd.setCursor(0, 0);
  // print from 0 to 9:

   lcd.print("Temp: ");
   lcd.print(t);
   lcd.print("C");
  
  // set the cursor to (16,1):
  lcd.setCursor(0,1);
  lcd.print("Humidity: ");
  lcd.print(h);
  lcd.print("%");
    
  Serial.print("Temp: ");
  Serial.print(t);
  Serial.print("C, Humidity: ");
  Serial.print(h);
  Serial.println("%");

}

I tried to cut and paste the error message, but my post exceeded the 9000 character limit. I zipped them in Notepad and attached. If there is a better way to do this, please let me know.

Thanks again,
Michael

Error Code Temp Humid LCD.zip (1.34 KB)

 #include <../Wire/Wire.h>

Have you bothered to search for error messages concerning this mess? No, of course not.

Change that to #include <Wire.h>. The dipstick that wrote that library ASSumed that the Wire library would always be in the same place relative to the library that uses it. Not a valid assumption AT ALL.

Hello again,

To PaulS, your quick and acerbic response was unfortunately not the fix. You asked and answered whether or not I had tried to find the answer myself. You,as you put it about the author of the sketch, ASSumed that I hadn't. You answered your own question as to if I had, with "of course not". Again, I had. Instead of you approaching this as a teachable moment, you took the time to deride me. Believe me, I am well aware of the fact that I have mountains of learning in regards to Arduino. That's probably why it says Newbie by my name. It is however, extremely pleasant to receive your words of encouragement on my very first post to the forum!

To anyone else who reads this, I did find my problem. I don't know why or how, but the wire library must have been corrupted. I deleted the library, downloaded a fresh copy and installed it. The program passed verification and is now working.

Best regards, Michael