Need help with Due R3

Got my Arduino Due R3 today. Ran into various problems.

Problem: Can't upload any sketches.
Symptoms: ON and L (13) are always on. The board had a blinking script on, but as soon as i pressed "erase", the described happened.

Reset button nor erase button seem to do nothing.

Loopback test confirms that drivers, IDE and USB-serial converter are working. RX TX light up.

When uploading, the following is given:

Arduino: 1.6.4 (Windows 8.1), Board: "Arduino Duemilanove or Diecimila, ATmega328"

Sketch uses 1,068 bytes (3%) of program storage space. Maximum is 30,720 bytes.

Global variables use 11 bytes (0%) of dynamic memory, leaving 2,037 bytes for local variables. Maximum is 2,048 bytes.

C:\Users\User\Documents\arduino-1.6.4\hardware\tools\avr/bin/avrdude -CC:\Users\User\Documents\arduino-1.6.4\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM4 -b57600 -D -Uflash:w:C:\Users\User\AppData\Local\Temp\build7242746090316680099.tmp/sketch_may14a.cpp.hex:i 



avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58

         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         Copyright (c) 2007-2009 Joerg Wunsch



         System wide configuration file is "C:\Users\User\Documents\arduino-1.6.4\hardware\tools\avr/etc/avrdude.conf"



         Using Port                    : COM4

         Using Programmer              : arduino

         Overriding Baud Rate          : 57600

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xc3

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xc3

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xc3

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xc3

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xc3

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xc3

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xc3

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xc3

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xc3

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xc3



avrdude done.  Thank you.



Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

  This report would have more information with
  "Show verbose output during compilation"
  enabled in File > Preferences.

Using Native USB port gives the same error. Only difference is "resp=0x1e".

Port and Board are correct. COM 4 (COM 7 with Native USB) with "Duemilanove and Diecimila".

Tried various drivers, none with different result (sometimes saying "COM 4 access denied).

Any pointers on what to do? I do not own a different board and cannot burn bootloader (unless with the risk of Bitbang method, which I'm not 100% sure how).

Holy S***! I got it to work!

For some reason SAM board version 1.6.4 didn't work. Looked over such stupid tiny detail and nothing worked. Installed 1.6.3 and all works. Yay!

4 hours of trial and failure totally worth it.

Btw, if anyone else has SAM (32-bit ARM Cortex M3) boards, be sure to download it from under the "Board manager". Normal Due will not work.

[TOPIC CLOSED]