Need help with HMC5883L

I need help with this error please
'class HMC5883L' has no member named 'SetScale'
Thanks

You have an error in the code you didn't post.

HTH

1 Like

yes I have an error :rofl:

...and you still haven't posted your code
image

maybe you simply using the wrong library with your code (which we cannot see!)

have about if you try this library and its example code?

still get the error?

hope that helps...

1 Like

Well it's setScale in that library, not SetScale.

a7

1 Like

I managed to fix it and it's working..but I have a different and weird issue now...when I unplug the Arduino (uno or mega...I tried them both)...and plug it back...it's not working!!!!

Thoughts and prayers.

This is a very common observation on the forum, but it conveys surprisingly little information.

The number of exclamation points does tend to vary, though.

If you don't like my question....simply ignore it!

You haven't posted a question yet (or code), but please be assured, when you do, I will.

Better yet, I've put you on my "ignore" list.

1 Like

I