Need restart IDE after compile

Hi everyone,

I have installed Arduino IDE 1.8.13 and have very annoying problem with it (i guess). I have to restart the IDE after every single compilation/upload.

I've tried simple exmaple program Blink on boards Arduino One and NodeMCU 1.0 (ESP-12E Module). I can compile my program once but if i click to compile once again (even without any changes in code) i've got a error message

Error compiling for board NodeMCU 1.0 (ESP-12E Module).
  • here is for NodeMCU but the same problem occurs with base Arduino One.

I've read about some problem with cache. In preferences.txt i've tried to manipulate of the following parameters: cache.enable=false/true compiler.cache_core=false/true But no matter if those parameters are set to true or false it doesn't solve the problem.

I've read also i can be a problem with long paths in Windows but:

  1. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem - LongPathsEnabled = 1 ... and never experienced any problem with long paths
  2. On my old machine (same windows version) where i have IDE 1.8.10 everything works fine (and btw. there LongPathsEnabled is set to 0).

Any ideas?

File -> preferences, enable verbose output when compiling, try to compile again, and post the error it prints when attempting to compile.

okay no problem but i don't think someone can find anything basing on it - but maybe i'm wrong

Arduino: 1.8.13 (Windows 10), Board: "NodeMCU 1.0 (ESP-12E Module), 80 MHz, Flash, Disabled (new can abort), All SSL ciphers (most compatible), 4MB (FS:none OTA:~1019KB), 2, v2 Lower Memory, Serial1, None, Only Sketch, 115200"




D:\Arduino\arduino-builder -dump-prefs -logger=machine -hardware D:\Arduino\hardware -hardware C:\Users\mdoma\AppData\Local\Arduino15\packages -tools D:\Arduino\tools-builder -tools D:\Arduino\hardware\tools\avr -tools C:\Users\mdoma\AppData\Local\Arduino15\packages -built-in-libraries D:\Arduino\libraries -libraries C:\Users\mdoma\Documents\Arduino\libraries -fqbn=esp8266:esp8266:nodemcuv2:xtal=80,vt=flash,exception=disabled,ssl=all,eesz=4M,led=2,ip=lm2f,dbg=Serial1,lvl=None____,wipe=none,baud=115200 -ide-version=10813 -build-path C:\Users\mdoma\AppData\Local\Temp\arduino_build_796024 -warnings=none -build-cache C:\Users\mdoma\AppData\Local\Temp\arduino_cache_597703 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.mkspiffs.path=C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\tools\mkspiffs\2.5.0-4-b40a506 -prefs=runtime.tools.mkspiffs-2.5.0-4-b40a506.path=C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\tools\mkspiffs\2.5.0-4-b40a506 -prefs=runtime.tools.xtensa-lx106-elf-gcc.path=C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\2.5.0-4-b40a506 -prefs=runtime.tools.xtensa-lx106-elf-gcc-2.5.0-4-b40a506.path=C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\2.5.0-4-b40a506 -prefs=runtime.tools.python3.path=C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\tools\python3\3.7.2-post1 -prefs=runtime.tools.python3-3.7.2-post1.path=C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\tools\python3\3.7.2-post1 -prefs=runtime.tools.mklittlefs.path=C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\tools\mklittlefs\2.5.0-4-fe5bb56 -prefs=runtime.tools.mklittlefs-2.5.0-4-fe5bb56.path=C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\tools\mklittlefs\2.5.0-4-fe5bb56 -verbose C:\Users\mdoma\Documents\Arduino\Blink\Blink.ino

D:\Arduino\arduino-builder -compile -logger=machine -hardware D:\Arduino\hardware -hardware C:\Users\mdoma\AppData\Local\Arduino15\packages -tools D:\Arduino\tools-builder -tools D:\Arduino\hardware\tools\avr -tools C:\Users\mdoma\AppData\Local\Arduino15\packages -built-in-libraries D:\Arduino\libraries -libraries C:\Users\mdoma\Documents\Arduino\libraries -fqbn=esp8266:esp8266:nodemcuv2:xtal=80,vt=flash,exception=disabled,ssl=all,eesz=4M,led=2,ip=lm2f,dbg=Serial1,lvl=None____,wipe=none,baud=115200 -ide-version=10813 -build-path C:\Users\mdoma\AppData\Local\Temp\arduino_build_796024 -warnings=none -build-cache C:\Users\mdoma\AppData\Local\Temp\arduino_cache_597703 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.mkspiffs.path=C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\tools\mkspiffs\2.5.0-4-b40a506 -prefs=runtime.tools.mkspiffs-2.5.0-4-b40a506.path=C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\tools\mkspiffs\2.5.0-4-b40a506 -prefs=runtime.tools.xtensa-lx106-elf-gcc.path=C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\2.5.0-4-b40a506 -prefs=runtime.tools.xtensa-lx106-elf-gcc-2.5.0-4-b40a506.path=C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\2.5.0-4-b40a506 -prefs=runtime.tools.python3.path=C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\tools\python3\3.7.2-post1 -prefs=runtime.tools.python3-3.7.2-post1.path=C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\tools\python3\3.7.2-post1 -prefs=runtime.tools.mklittlefs.path=C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\tools\mklittlefs\2.5.0-4-fe5bb56 -prefs=runtime.tools.mklittlefs-2.5.0-4-fe5bb56.path=C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\tools\mklittlefs\2.5.0-4-fe5bb56 -verbose C:\Users\mdoma\Documents\Arduino\Blink\Blink.ino

Using board 'nodemcuv2' from platform in folder: C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.7.2

Using core 'esp8266' from platform in folder: C:\Users\mdoma\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.7.2

Detecting libraries used...

Error compiling for board NodeMCU 1.0 (ESP-12E Module).

Ohhhhh! It's THAT bug! The "error compiling for board" with no other information.

There is a straightforward fix for that, and I used to remember what it was, but then people stopped running into it for a while, and since then I've forgotten how to fix it... The fix is in this section somewhere...