Nessun dato ricevuto GPS Shield Sparkfun e EM406A

Salve a tutti, sto lavorando ad un progetto che prevede l'utilizzo di una shield GPS. Io possiedo un Arduino YUN, una shield GPS Sparkfun e un modulo GPS EM406A. GPS Shield: https://www.sparkfun.com/products/10710 Datasheet EM406A: https://www.sparkfun.com/datasheets/GPS/EM-406A_User_Manual.PDF

Ho seguito il procedimento spiegato nel tutorial di Sparkfun (https://www.sparkfun.com/tutorials/173), ho provato diversi sketch, sia quello fornito da sparkfun (http://dlnmh9ip6v2uc.cloudfront.net/datasheets/Dev/Arduino/Boards/gps_arduino_1_0_1.ino) nel tutorial citato prima sia altri che ho trovato nel forum di Arduino e di Sparkfun ma il risultato è sempre lo stesso: non mi viene restituito nessun risultato sul serial monitor anche se il led del modulo GPS lampeggia (il che vuol dire che il modulo ha fissato la posizione).

Non riesco a capire quale sia il problema, se di Hardware, di Software o qualche altro problema.

Grazie in anticipo a chi mi aiutera.

Hai correttamente settato il Jumper su DLINE ? Perché il codice di esempio usa la SoftwareSerial di base sui pin 2 e 3 ... :roll_eyes:

Guglielmo

Si però non mi restituisce niente lo stesso

Fai una foto di come hai assemblato il tutto (possibilmente nitida) e verifichiamo se c'è qualche problema a livello elettrico ...

Per allegarla, quando scrivi il messaggio, fai click in basso, dove c'è "Additional Option".

Guglielmo

Io ho semplicemente collegato la shield sopra allo YUN.

In effetti sembra collegata bene ... ... un solo dubbio ... non è che per caso qualche componente/saldatura fa contatto con gli schermi metallici dei due connettori presenti sulla Yún (Ethernet e USB Host) ?

Guglielmo

No tra la shield e gli schermi metallici dei due connettore ci sono circa 2-3 millimetri di spazio.

Vedo che la tua shield è leggermente differente ... ... sei sicuro che i pin 2 e 3 siano connessi e non devi saldarli ??? ... leggi il punto 3 del tutorial e, [u]a scheda staccata[/u], prova con un tester che effettivamente i pin 2 e 3 dello shield siano collegati al RX e TX del modulo GPS ... :roll_eyes:

Guglielmo

Scusa, ma cosa intendi per scheda staccata?

Che quelle misure le devi fare con la scheda poggiata su un tavolo, NON alimentata e NON connessa ad Arduino … devi misurare la continuità dei collegamenti, quindi …

Guglielmo

Ho fatto la prova con il tester come mi hai detto tu e mi risulta che c'è continuità tra RX e TX del modulo GPS e i pin 2 e 3 della shield

Mmmm ... :roll_eyes:

Non conosco bene la Yún, ma guardano il reference i pin 2 e 3 sono usati solo per il bus I2C :

TWI: 2 (SDA) and 3 (SCL)

... e se non hai nulla su I2C ... dovrebbero essere liberi.

Onestamente al momento non mi viene in mente null'altro ... ci vorrebbe qualcuno che conosce bene la Yún per essere sicuri della compatibilità del tutto ...

Hai provato a scrivere al fornitore per sapere se ci sono incompatibilità con la Yún ???

Guglielmo

Proverò a contattare il produttore. Però quando l'ho acquistata in negozio mi avevano assicurato che sarebbe stata compatibile per lo YUN, e poi avevo guardato sul forum del produttore e sui commenti alla shield sul sito del produttore e qualcuno diceva di utilizzare Arduino YUN ma nessuno ha citato dei problemi come questo.