network problems w/ Uno and OSX10.4.11

I'm new to this stuff, but trying . I was able to upload blink to the Uno from a Mac running the most recent OS, but my reliable old titanium powerbook running 10.4.11 has network problems.

Trying to upload, the error I get is

avrdude: stk500_recv(): programmer is not responding avrdude: stk500_recv(): programmer is not responding

board is identified as Arduino Uno serial port is /dev/tty.usbmodem1811

any hints as to my problem?

Thanks, grazie, Martin

  1. Double check you have Uno selected in the Drop-Down.

  2. The error you get is a generic error. Any search will tell show that. If a manual-reset doesn't work, then see #3

  3. There are known issues with the Uno working with 10.4.x Since the Uno relies on the OS's drivers, I don't think there was much that could be done.

Again pardon my ignorance, the 10.4.xx problems with drivers, is it hardware-related or software-related? I am wondering if it's worth trying to download other usb-serial port drivers or not. Although I guess that someone would have found the magical driver that works, if it existed. Poor Titanium Powerbook, after 9 years, it gets no respect.

Thanks, Martin

the 10.4.xx problems with drivers, is it hardware-related or software-related?

The issue is related to OSX 10.4'x USB-Modem drivers.

I am wondering if it's worth trying to download other usb-serial port drivers or not.

I'm not aware of other USB-Modem drivers that are available for OSX. If you find others, by all means try. However, you aren't really searching for "USB to Serial Port" drivers. For example, installing FTDI usb to serial drivers would change nothing (related to this issue.)

[quote author=James C4S link=topic=64816.msg474565#msg474565 date=1309062382]

the 10.4.xx problems with drivers, is it hardware-related or software-related?

The issue is related to OSX 10.4'x USB-Modem drivers. [/quote]

Do you know if 10.5 fixes this problem?

Thanks Dimitri

[quote author=James C4S link=topic=64816.msg474565#msg474565 date=1309062382]

the 10.4.xx problems with drivers, is it hardware-related or software-related?

The issue is related to OSX 10.4'x USB-Modem drivers. [/quote]

Thank you thank you thank you!!!!

Upgraded my PowerBook G4 Ti from 256MB to 1 GB and from OSX 10.4.11 to 10.5.6 and all is well!