Never Ending Upload?

Ok I have a MegaAT1280 based board and have been having fun learning to program it. But as I did the basic sketches, on the fader sketch went to upload and… it just keeps saying “Uploading to I/O” and never finishes. If I try to close the arduino environment and reopen it says com3 is in use by other programs (I assume this is the last code push that never finished still running). I can unplug board and replug it in to circumnavigate this problem but again each upload to board never finishes… justs keeps “uploading”. I have the proper board selected, com3 selected, and windows still says driver is properly operating (I am using Win 7 64bit Pro). I’ve tried restarting the system, tried different usb ports, tried resetting board… i am at a dead halt out of nowhere as far as I can see. When plug in the power light comes on as does a light next to tx2. If anyone can be of help to a noob that is pretty serious about learning arduino, it would be greatly appreciated.

Do you have anything connected to RX/TX?

I had the same problem. But I use Arduino Duemilanove.