New Arduino 2560 HELP !!!

Hi,
yesterday i received my Arduino mega 2560.
After loading the software and the libraries i connected the device to my PC and i tried to execute blink program but…
Aa soon as i connected the led and the resistance the led begins to blink as the L led on the Arduino board without loading the blink program.
I tried to reset Arduino but it seems that the reset button doesn’t execute the reset command.
I tried to load the Fade program but i received a message saying that the com port was not available. I ought to stop any program that was running (there was no program running) and try again.
I tried to change the serial port 1 with 11 with no results.
The serial monitor seems not working…

Please help me if possible :slight_smile:

Thanks in advance,

Maurizio Balvetti

I still get those errors every now and then after using my Mega for a week or two. I just generally unplug/close/replug/open whatever hardware and software is even remotely related and eventually it comes back.

This also seems to happen if I haven't uploaded for some time, maybe a couple of hours or something.

Go figure.


Rob

Hi all,
i try on imac computer and everything works great.
I think that might be a communication problem. Could anyone help me to solve this ?

It is a little expensive to buy an iMac to allow Arduino works :-))

Thanks in advance,

Maurizio Balvetti

Aa soon as i connected the led and the resistance the led begins to blink as the L led on the Arduino board without loading the blink program.

The blink program comes preloaded.

I tried to reset Arduino but it seems that the reset button doesn't execute the reset command.

A reset does not erase the memory. Every time you press reset the preloaded blink program just runs again.

I tried to load the Fade program but i received a message saying that the com port was not available.

Until you fix this communication problem your Arduino will keep blinking whenever power is applied. If you have loaded a different program with your mac then that program will run each time power is applied.

Don

Thanks for your informations. It seems that Arduino logic works like Parallax's Basic Stamp 2. Anyway now i can test Arduino's programs on my friend's Mac :-)

For help getting the board working on your Windows machine, check the troubleshooting guide: http://www.arduino.cc/en/Guide/Troubleshooting#upload