new Arduino ethernet board

I have tried all the Ethernet example sketches using the new Ethernet board ( this is not the Ethernet shield). They just do not work. Is the built in AVR Atmegas wiring different to the Ethernet shield board? All the other programs seem to work, like serial, SD card etc. but I cannot get the Ethernet ones to work. I am using Arduino 1.0. I am using the standard libraries that came with 1.0.
The last try was the webclient example software. It just seems to hang in the “ethernet.begin” routine?
Any ideas of what I need to do?

Are you using dhcp to get an ip, and it never returns from that function? If so, you might want to try IDE v1.0.1. Here is a link to the downloads.,72232.msg727530.html#msg727530

After a long day, webclient talks to google. Now the other examples. Thanks. 1.01 RC1 works so far

So far all these examples have worked. DHCP Webclient webserver UDPNTP

Yes, I went through the same sequence, though most of my problems
were with the cross-compiler. 1.0.1-rc2 is out, and it might be worth
upgrading. I’ve used it for both HTTP and Telnet (and DHCP of course)
and it works fine on the Arduino Ethernet. (I haven’t tried it on the
Ethernet Shield.)

The Ethernet library compiles with a few warnings, but I think you can
ignore them.