New Code - 'expected unqualified ID before ':' token'

Hi everyone,

So i have never coded before so please excuse me if this is a stupid question.

I found a code on github for an animatronic project. My soldering is all done but when i try to code my attiny13 chip it comes up with an error message 'expected unqualified ID before ':' token'

The code used is the one below. Can anyone see an obvious issue? Thanks

:1000000048C008C007C007C005C004C003C002C084
:1000100001C000C018951F931FB71F93BB2019F490
:10002000AA2011F0AA94BA94839509F473957230BA
:1000300039F48E3E29F470E080E018B31F6018BBDD
:10004000772361F4891709F4C0988A1709F4C198D5
:100050008B1709F4C2988C1709F4C39860E016B3A3
:10006000107119F040E050E00AC0539509F443952F
:100070004E3028F0563A18F04EE056EA61E0CC20B7
:1000800019F4DD2011F0DA94CA941F911FBF1F915B
:1000900018951FE017BB13B7187F116013BF19B76E
:1000A000126019BF8824442755276627AA24BB2439
:1000B00077278827FF24DD24CC2400E030E0F89463
:1000C00090E5AEE1B8E2C6E478942227112778944F
:1000D000F0E0EDE6E30FF81D099406C00CC012C075
:1000E00018C01EC024C02AC0F89490E5AEE1B8E262
:1000F000C6E4789429C0F89495E5A9E1B9E1C5E58D
:10010000789422C0F8949EE1A0E5B6E4C8E2789421
:100110001BC0F89490E5A7E3B6E4C6E4789414C055
:10012000F89490E5A7E3B8E2C6E478940DC0F8949B
:1001300090E5A7E3B6E4C6E4789406C0F89490E5A9
:10014000AEE1B8E2C6E47894F0E0E9EAE00FF81D29
:1001500009940DC017C020C024C034C043C047C09C
:1001600056C05DC05CC05BC067C073C07FC030E07C
:10017000662339F1F89422E3A22E2FEFB22E01E08C
:1001800078941FC0AA2021F4BB2011F402E019C00A
:100190006623B9F403E015C031E0662391F400E072
:1001A00010C0662341F0F89422E3A22E2FEFB22E66
:1001B00004E0789406C0AA2021F4BB2011F400E0EA
:1001C0005CC05BC0AA2021F4BB2011F405E0F9CF8C
:1001D0006623B9F7F89422E3A22E2FEFB22E06E0A1
:1001E0007894EFCF32E0662361F700E0EACF662330
:1001F00041F0F89422E3A22E2FEFB22E07E078947C
:100200003CC0AA20F1F6BB20E1F600E036C0F8942D
:1002100029E1D22E2FEFC22E0AE078942EC033E0CF
:10022000DD2049F4CC2039F4F89429E1D22E2FEFC7
:10023000C22E0BE0789421C034E0DD2049F4CC20BC
:1002400039F4F89429E1D22E2FEFC22E0CE07894E5
:1002500014C035E0DD2049F4CC2039F4F89429E1CC
:10026000D22E2FEFC22E0DE0789407C036E0DD20AD
:0C02700019F4CC2009F400E000C02ACFF3
:00000001FF

Coding.png

Coding.png

Where have You learned and seen code presented like this?
Watched any topics here before?

You’re trying to compile a hex object file.
Don’t bother, it’s already been compiled.
Just upload it.

TheMemberFormerlyKnownAsAWOL:
You're trying to compile a hex object file.
Don't bother, it's already been compiled.
Just upload it.

Sorry how do i do that? I haven't done this before. First project?

Now I’m puzzled - I just looked at the picture (Grrrr…) in the original post, and the file is described as a .ino

Where did you find the project?

This is the project. I have it as an .ino file and a .hex file. I got it as both just so i could try either.

I have gone through a few tutorials and i still can't get it to work. I have now gotten the Arduino software and i have attached the error message below.

I am having no issues with the electrical side. I just cannot get the software side to work. This side isn't my forte alas.

Sorry hope this makes sense due to my inexperience I'm not sure.

Coding 2.png

Coding 2.png

TheMemberFormerlyKnownAsAWOL:
Now I’m puzzled - I just looked at the picture (Grrrr…) in the original post, and the file is described as a .ino

Where did you find the project?

Sorry posted above and forgot to quote.

Did you miss this?

TheMemberFormerlyKnownAsAWOL:
Did you miss this?

Honestly it didn’t make a huge amount of sense to me. Feel a little thick for not getting this.

Hello rveldon,
Welcome.

I've just had a look at that Destructible post and it reminds me why they are hated here. I didn't read it in full, just skimmed through it. It doesn't tell you in any detail (that I saw) how to upload the code. What it does tell you is that's a hex file, which is ready compiled code to upload, they have kept the source code secret so you can't see it or modify it. The Arduino IDE expects source code, which you don't have.

My opinion is that is is not fair or reasonable to ask us here for help. The tutorial is on Destructibles so you should ask there, ask the author to explain how to use her code, not ask us to guess what she intended. The only places 'Arduino' is mentioned on that page is in the comments, not in the instructions, so what brought you here?

Please, in future, do not post images of code, they are useless, please post the actual code in code tags as per the instructions you were directed to before you posted.

Good luck getting your project to work.