New forum instructions, feedback and comments

You will perhaps have noticed that I have created a new version of the forum instructions for beginners. I am always looking for feedback and comments to improve what I have created, if you have any ideas or comments that you think would improve them please post here. I don't want any comments in the instructions as they would distract from their purpose of helping newbies.

My aim was to create some short, simple, quick to read instructions that would be enough to get most people started, with links to longer instructions for those that wanted more help. I have also tried to include something about the most common mistakes made by newbies so as to reduce the constant replying to people about using code tags, cross posting.... you know them all ! ! ! If I've missed some common problem here is the place to tell me.

Please read the new instructions and provide feedback here.

I thank you.

1 Like

Perry - thanks for the hard work that obviously went into that. I just hope that we can get people to read it

There are references to uploading an image but I didn't find any instructions but I may well have missed it. Of course, since a recent change you don't need to upload an image explicitly, merely attach it and it will be shown with your post.

Bob:

Schematics:
The language of electronics is a schematic or circuit diagram. Long descriptions of what is connected to what are generally useless. A schematic is a drawing of what connects to what, please make one and photograph it. We don't mind if it's hand drawn, scruffy and does not use the correct symbols. We do mind if you don't at least try to post a schematic. To include a jpg image of your schematic just upload to your post and the forum software will automatically display it for you.

OK, but can I suggest that you revise the description because there is no “upload” functionality, rather you need to attach the image and that is only possible if you use Reply rather than Quick Reply or use Quick Reply and then Preview the post

It is amazing how many ramifications there are to such a simple thing

It is amazing how many ramifications there are to such a simple thing

I know, and this is the one thing I was not entirely happy with. I need to do some more work on the long version. I will give some more thought to this for the long version, it is too complicated to just skip over. I probably won't do it today though.

UKHeliBob:
Of course, since a recent change you don’t need to upload an image explicitly, merely attach it and it will be shown with your post.

There are ramifications to that too … :slight_smile:

{A} finding the place with the attach option
{B} the Forum rejects JPGs with Exif data
{C} the image may already be hosted on another website so only a link is needed.

I think this Simple Image Posting Guide covers all these.

…R

For the language section it may be better to user the URL list

It is complete but maybe seperate with line breaks for easier reading ?

[list]
[li][url=https://forum.arduino.cc/index.php?board=99.0]中文 (Chinese)[/url][/li]
[li][url=https://forum.arduino.cc/index.php?board=31.0]Deutsch - German[/url][/li]
[li][url=https://forum.arduino.cc/index.php?board=32.0]Español  - Spanish[/url][/li]
[li][url=https://forum.arduino.cc/index.php?board=33.0]Français - French[/url][/li]
[li][url=https://forum.arduino.cc/index.php?board=82.0]অসমীয়া,  বাংলা,  बड़ो - India[/url][/li]
[li][url=https://forum.arduino.cc/index.php?board=34.0]Italiano - Italian[/url][/li]
[li][url=https://forum.arduino.cc/index.php?board=77.0]Nederlands  - Dutch[/url][/li]
[li][url=https://forum.arduino.cc/index.php?board=35.0]Portugues - Portuguese[/url][/li]
[li][url=https://forum.arduino.cc/index.php?board=120.0]Россия - Russia[/url][/li]
[li][url=https://forum.arduino.cc/index.php?board=36.0]Scandinavia  Swedish, Suomi - Finnish, Norsk - Norwegian[/url][/li]
[/list]

Thanks Bob,

I've done it in the full version. The link in the short version takes you to the correct section with the links to the various language boards.

Perry

I had a quick glance as I was looking for the original (older) sticky that used to be in the Installation and Troubleshooting section.

I can’t find the old sticky any more.
2)
I could not find a description of [code] and [/code] as in the old sticky; I think I saw something about </>, not even sure.

The short version of the new forum instructions has been deployed in (almost) every section of the forum.

You might be wondering about the full version; I am still working on it. There is plenty about it that I'm not happy with. I am somewhat exhausted from what I have done already so it might be a while before I make the changes I want to do. If you see improvements with the full version that you would like me to consider please post them here.

Thanks.

I have some pre-prepared text that links to How to use the forum

Can you confirm that the idea is that I should now change those to refer to your new short version?

...R

Hi Robin,
Yes, that’s the Idea.

Perry

PerryBebbington:
You will perhaps have noticed that I have created a new version of the forum instructions for beginners.

Good work. It should prove useful.

If you are making your first post you will have been re-directed here where we explain how to get the best out of this forum...

Kudos to the site admin for implementing this.

A suggestion: A recent poster apologized for a duplicate. Perhaps a tip could be added in the instructions letting the offender know the 'report to moderator' link to request to have a post moved is preferred over risking "the wrath of the moderators" after the fact.

:slight_smile:

dougp:
Good work. It should prove useful.
Kudos to the site admin for implementing this.

A suggestion: A recent poster apologized for a duplicate. Perhaps a tip could be added in the instructions letting the offender know the 'report to moderator' link to request to have a post moved is preferred over risking "the wrath of the moderators" after the fact.

:slight_smile:

Site admin didn't have much to do with the one shot and it was only pushed out properly this morning in here for final testing.

Pretty much most of the recent improvements came directly or indirectly from forum members.

I've just tested the redirect for a newbie and it worked.

Bob, please delete the account and the post.

Thanks.

PerryBebbington:
I've just tested the redirect for a newbie and it worked.

Bob, please delete the account and the post.

Thanks.

I better not delete THAT account :fearful:

Link me to the post or account that needs to be killed.

This post:

https://forum.arduino.cc/index.php?topic=712449.0
And associated account.

Thanks!

I better not delete THAT account

Just remember that revenge is a dish best served cold....
:slight_smile:

Thanks Perry for your work on this.

Mind you if I get banned again by the security software, you will not read this thank you :confused:

larryd:
Thanks Perry for your work on this.

You're welcome :slight_smile:

BTW,
After I made the test post and logged back in to this account as soon as I tried to make a post on THIS account I got redirected to the newbie instructions. Maybe look out for this happening to others. Could just be a cookie thing from logging in on a different account.

ballscrewbob:
Site admin didn't have much to do with the one shot and it was only pushed out properly this morning in here for final testing.

Oh, I thought they were responsible for such.