New Freenove Uno, Cannot upload programs

Newbie here. Have Freenove UNO. Plugged in to Battery first and power green led ok with Led L flashing orange. Plugged into computer usb port still power led ok and Led L flashing.
Downloaded IDE ok. Arduino 1.8.15. Set up UNO and com port ok, Loaded "Blink" and led still kept blinking at 1 second as per Blink.
Tried modifying Blink by changing time only to 4000 instead of 1000. saved sketch with new name. Checked code to make sure only change in number.
Brought in new file with modified time and no change. Did this with different number a second time, Did all the things suggested, disabled bluetooth, resetting, different keystrokes , changed to different cable etc . No change flashing Led L and green power on. It looks as though Blink is permanently running!!!. Can somebody help. Do I have a dud board or is it something simple that I did not do?

Sounds like the upload didn't succeed.
Tick the "verbose upload" option in preferences, try uploading again, and post the output here.

From your description, it sounds like you think changing the file and saving it affects the UNO. I have had a couple of students who also thought this.

You need to upload the code to the UNO by slecting the correct COM port in the TOOLS menu and then clicking the icon at the top of the IDE with an arrow pointing right to upload. If i have this wrong, I do appologise.

Thanks for your helpful replies.
The laptop I was using is old using Windows Vista Home Premium.
I tried it out with my new Windows 10 AIO (all in one). All worked fine and programs worked fine.
My new problem is to get a download that will allow it to work with Windows Vista.
I will search the forum for this.

Thanks for your help