New Laptop won't upload to Arduino board

Hello, I am having an uploading problem only with my new Laptop. I have tried Windows support and two local repair shops. Can't get help anywhere. So, I hope the someone here might be able to help by looking at the Avrdude error.
My USBs work with flash drives. However, they won't work with an Arduino board or an external drive. I've tested these on other machines and they work fine.

The message I get is:

An error occurred while uploading the sketch

avrdude: Version 6.3-20190619

     Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

     Copyright (c) 2007-2014 Joerg Wunsch

     System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

     Using Port                    : COM3

     Using Programmer              : arduino

     Overriding Baud Rate          : 115200

avrdude: ser_open(): can't open device "\.\COM3": The semaphore timeout period has expired.
avrdude done. Thank you.

Problem uploading to board. See Upload – Arduino Help Center for suggestions.

I tried the link here but really can't make sense of it. Any help would be greatly appreciated

you need to make sure you are using the correct settings in the editor select the board that you are using and the correct port I suggest try putting a sample code on your board first to make sure the boards functioning properly. I'm a newbie to arduino myself but I had this issue the first time too.

Thanks for your help. The Arduino does work on other laptops

Which Arduino board(s)?

Google: avrdude: ser_open(): can't open device "\.\COM3": The semaphore timeout period has expired. site:forum.arduino.cc - Google Search

There are plenty hits, you will have to dig through them and try possible solutions. One thing might be a bluetooth adapter interfering, see if you can switch it off. This is another one where the issue was solved by assigning a com port in Windows device manager: Can't ipload to Arduino Uno - #3 by gomanalexandru

What Arduino board are you using?

What OS is on the laptop?

Can you hear the Microsoft USB "bing-bong" when connecting your board?

Go to:
In the Windows Search box type Device Manager press enter

You should see your com port and some indication of what is connected here:

Thank you, this looks helpful