New Mac IOS 11.6 Big Sur cause problems?

I tried to download a sketch into Arduino Uno and keep getting the error message: Error compiling for board Arduino Uno, exit status 1. There appears to be nothing wrong with my connections to the Mac USB output, and no problems in the past. The new MAC IOS 11.6 has been updated on my MAC. Could this be a problem?? I'm stumped.

Compiler errors have nothing to do with your USB connection.

  1. Please post your sketch.
  2. Please post the complete error message. When you get an error, the orange bar will have a button 'copy error messages'; click it to copy the error messages to the clipboard and next paste it in a reply.
  3. Which version of the IDE?

When posting code or error messages, please use the </> button to apply code tags.

Thank you for the reply. You are correct, seems not to be a USB issue. We have found the problem. It's with the library we are using, i.e., DHT for the DHT11 Temperature and Humidity module. The latest version 1.4.2 seems to be defective. We uploaded multiple empty sketches that uploaded perfectly. Then we ran uploaded empty sketches with just the #include library command from other libraries. They ran perfectly. Then we ran the following: #include <DHT.h> and many other DHT commands. Just like we did with the other test library sketches that worked fine. They all failed to upload with the following error message.
Error compiling for board Arduino Uno.
exit Status 1

We did find a few other libraries that also failed to upload, and had the same message. There appears to be a problem with some of the libraries uploading. I'm trying to remove the previous updated DHT library and upload an older version, 1.3.4 that appeared to work in a tutorial posted last year. Maybe that will work. But, it's definitely some sort of library problem.

I have no idea as you haven't provided the full error message nor the sketch. Be aware that there are multiple DHT libraries so if you pick the wrong one, existing code might not work. Same applies for e.g. the I2C LCD libraries.

My advise would be to check some of the examples that come with the library and compare them to what you do in your sketch.

Deleting a library is simply a matter of navigating to the library subdirectory of the sketch directory and deleting the specific library directory; you might have to restart the IDE after that.