New Mini-uino

I've been working with Robert trying to get this running, he's been very helpful, but I'm still stuck.
Optiloader was loaded successfully.

I connected
GND,+5,RST,TX,RX on my Uno.
Removed the 328 chip.
Still it will not load sketches.

L light does not come on (UNO).
The TX LED does not come on.
The RX LED flashes a few times 1 second apart.

Please can you tell me what steps to follow to troubleshoot?
If you ask me questions it would be very helpful.
I'm not sure what more information I need to include.
I get the same error as if nothing were connected (chip removed).

What does the boards.txt entry for the Mini-duino look like? Does it have the right baud rate for the Mini-duino optiboot bootloader?

Great question! There is no entry for this board. I was told to use the same choice as the existing chip in the Uno, which is now removed. What is the baud rate for Tools/Board/Arduino Uno? What is the right baud for Mini-uino Optiboot? I used this Sketch to load it following the instructions. I did not modify the sketch.

Looks like it should have worked, assuming the selected UNO and the Mini-duino use the same processor. Sorry I can't be of more help.

  1. How do you know that the optiloader was loaded correctly?

  2. How about posting some pictures of your setup.

  3. What did you use for an oscillator/crystal?

Try reversing RX and TX on your Uno

Here's the mini-uino design.
Same '328 processor as the Uno. Different package, same device signature.
Same pinout used as an Arduino.
Connecting +5, Gnd, Reset, D0, D1 to Uno should let it look like a '328 is plugged into the board.
I can't see where the issue is here, we've traded several e-mails on this already.
I figured he'd be golden after loading the optiloader worked.

  1. There were no error messages when I ran the Sketch. Every line looked good and it said success or something. I wish I had saved the text.

  2. Will post pictures. There are 5 wires and 9 components soldered to the PCB. I have not yet done anything different on the PC. Just tried to upload a sketch like I always do. Removed the DIP chip on Uno.

  3. I used the Xtal that Robert provided A160LOX. He's been great at helping me BTW!

I tried reversing the TX/RX pins anyway. Although we thought carefully about which is correct.
"D1" to "TX"
"D0" to "RX"

What about using DTR instead on Mini like was mentioned on the other thread above mine?

Why is there a "1" next to "D0" on PCB printed in white?
Looks almost like "D01" except 1 is upside down.
There is also a "1" next to D5.

Also tried:
D10 to Mini-uino Reset,
D11 to D11,
D12 to D12,
D13 to D13,
+5 to +5,
Gnd to Gnd
using Sparkfun USB Xbee dongle.
Same error.

Just tried again like this:

The extra digits are part of the symbol around the connector, I'm terrible at manipulating symbols so I just left them there.

I wonder if there is some fuse setting thing that needs to be done as part of the optiload boot loader?

Didn't you do this process with the same PCB?
How is my setup different?
I've tried 2 different methods, different pins, different hardware.
So it can't be just 1 bad solder joint.
The only thing they have in common is our PCB.
Maybe I have a soldering defect.
How do I troubleshoot?
Keep in mind the Optiloader process was a success.
Maybe I have made a stupid mistake, I'm new to Arduino.
Something so obvious to everyone they forgot to tell me?
That's why I need your questions! No question is stupid or insulting.
Did you remember to plug in the USB cable? :wink:

When I press reset with my old DIP 328 the lights do a sequence.
Shouldn't I expect a similar response even without a Sketch in the new chip?
This does not require a good solder connection to RX.
Does it prove the problem is with TX or Reset?
(I tested power and GND)
Certainly we can eliminate anything related to the PC as suspect.

Let's assume I made a soldering mistake.
Which connections would fit the symptoms?
Works with Optiloader but not IDE loading sketches.
Seems there are only 3 possibilities?

The correct caps are marked 4x 104
2x 22
Res Brown Black Orange.
Getting desperate...

Thanks everyone for your time and effort so far,
especially Crossroads!

Let's assume I made a soldering mistake.
Which connections would fit the symptoms?
Works with Optiloader but not IDE loading sketches.

Serial Programming uses the SPI pins and regular uploading uses the serial port. Perhaps something is causing the serial port to not work properly. If the crystal or associated capacitors are bad that might cause the clock rate to be off. Just a guess.

John, I think you mean bootloader programming uses SPI and sketch (regular) uploading uses the serial port.

This should be no different than uploading to a promini.

With +5, Gnd, and D0 to D0, D1 to D1 and Reset to Reset, and having its own xtal/caps/reset pullup resistor,
the board should look & act just like a chip that was plugged in as far as the USB/Serial interface is concerned.

if you use a meter and buzz from D0 to D1, D0 to Gnd, and D1 to Gnd, you're not seeing any shorts are you?

No shorts.
I can see 3 problems according to this tutorial:

It says NOT the Uno, at the top, in bold.
It says to select a different controller in the Board menu.
I have 4 extra caps in my circuit.
Which one of these is a problem?

You are basically doing what is in the second picture at your link. You have burned the bootloader and are now trying to run a sketch. The additional caps are fine.

What exactly is your error? Are you getting an error message loading the sketch or is the problem that the "L" LED does not light up.

In your first post, you said the "L" LED does not light. It won't. If you are trying to run the "blink" program using the "L" led, you are not driving the LED. You will have to connect an additional wire to drive the LED. To do this, connect a wire from the mini-uino pin D13 to the uno pin labeled 13. If the sketch is loaded correctly, the "L" led should blink.

The IDE says "Problem uploading to board".
I would expect the L,TX,RX to act the same with both chips when uploading?
What is the L LED? I don't know, just that it blinks with original chip installed.
Reading... Ah I understand it should not blink. But TX should?

Yes, TX should blink but on the 5 wire setup you have, the "L" LED will not light or blink.

The last thing would be to take a picture of the back of the board where you have the capacitors soldered. Then post it here.

NOT the Uno only refers to the bootoading part.
The extra caps you have are power supply decoupling, Aref decoupling, and the DTR cap, which you are bypassing and connecting to Reset directly.

Once the bootloader is on the chip, the middle section should work the same:

"Uploading Using an Arduino Board

Once your ATmega328p has the Arduino bootloader on it, you can upload programs to it using the USB-to-serial convertor (FTDI chip) on an Arduino board.
[Or with an Uno, the ATMega8U2 performing as the USB-to-serial convertor - RWP]
To do, you remove the microcontroller from the Arduino board so the FTDI chip can talk to the microcontroller on the breadboard instead. The diagram at right shows how to connect the RX and TX lines from the Arduino board to the ATmega on the breadboard. To program the microcontroller, select "Arduino Duemilanove or Nano w/ ATmega328" from the the Tools > Board menu (or "ATmega328 on a breadboard (8 MHz internal clock)" if you're using the minimal configuration described below). Then upload as usual. "

Connect +5s, GNDs, Reset, and DO to D0, D1 to D1

Found a bad solder joint which sometimes works, especially when you press on it to test it!
The TX pin...

It's all good now! Thanks everyone!