New Pro Mini atmega328 5V 16M (clone) - not in sync - solved

Hello, i´m newie here, i write this topic to show how sync the arduino-clone “New Pro Mini atmega328 5V 16M Replace ATmega128 Arduino Compatible Nano” with “USB To RS232 TTL PL2303HX Auto Converter Module Converter Adapter For arduino”

(it took me hours to find how sync this little board)

Pin connection:
5V → VCC

1.Change the baud of the USB MODULE or “Prolific USB-to-Serial Comm Port” to 115200 bauds.
2.In the Arduino Sketch change the board to “Arduino Pro or Pro Mini (5V, 16 MHz) w/ ATmega328”
3.Open your program or select “blink” from the examples
4.Press RESET of the Arduino Clone an then press upload sketch and release the reset when show the message “Size of sketch…” or “Tamaño del binario” in my case (spanish version).

that is the solution for my case, sorry for my bad english.

Claudio from Chile



la foto 1.JPG

la foto 2.JPG

Hola Claudio soy Dany y hablo español tambien. Pero para que nuestros amigos programadores del mundo lo aprecien bien seguire en ingles! I have the same problem using an Arduino Pro Mini too. I followed your steps and the Blink sketch ran and worked well.

I connected the pins like you did it.
Before I load my sketch I press RESET button in the Arduino Pro Mini.
Next I hit Load sketch and
When this line appears: "Binary sketch size:" I release the RESET button and that's it.
It was the solution for me too. But my question is:

Do we need to perform 4th step above and I quote:

4.Press RESET of the Arduino Clone an then press upload sketch and release the reset when show the message "Size of sketch.." or "Tamaño del binario" in my case (spanish version).

every time we want to load a different sketch?? Is there another solution for this issue??
What do you think folks??

Solution: Use a USB/Serial adapter that supports the DTR pin to drive a 0.1uF cap to the Arduino Reset pin.
Many FTDI FT232 chip based adapters support that.(such as Sparkfun FTDI Basic, and MIKROE-483 from Mouser)
Also some CP2102 modules, find the "Bate" model on ebay that has DTR broken out to a thruhole you can easily access.

Thank you for your suggestions, CrossRoads. I will order one of those that you mentioned. In the meantime, Is there anyway I can get it working with the existing USB to Serial device that I already have without pushing and releasing the reset button all the time???

Thanks in advance again!!

What tenacity on your part to figure out the RESET button trick...with the perfect timing and all! I just ordered 2 of the Baites myself.

I’m having trouble getting this to work. I’ve tried the solution above and it doesn’t seem to work. If I hold the reset button down until I see the sketch size prompt, It doesn’t seem to do anything. But if I leave it, it will blink rapidly for a bit, then go back to slowly blinking. The FTDI cable only blinks green, (It has red and green leds).

Is there any way I can check the coms rather then just trying to program it?

Here is information where someone wired out the DTR line so the Arduino can do auto-reset for uploading a sketch.

-- Steven

This (original post) worked for me using one of these cheapies from Ebay.

I couldn’t get it to work on 115200 baud using Arduino 1.0.5 for which I had to modify the preferences file.
But did work ok on the default 9600 baud.

I found it more reliable to watch the first flash of the LED on USB dongle then watching for the message on screen to trigger the reset release.

Of course, the other method is to use another arduino as a programmer if you have a model where the chip can be removed.



alguem pode posar u video estou com o mesmo problema

Yes! this solution work great for me also.

A cable with dtr should be better. On the other hand how often are you going to upload new sketches to pro mini?

Make your prototype into a nano and then when finalize the project with a pro mini. These clones of arduino pro mini are so cheap (less than 4 euros) that you don’t mind soldering into the final project board

I suffer this issue for 1 day, and I use Arduino FTDI Basic FT232RL in Windows 7 64bit version

At last I found, the VCP driver 2.08.30 got some problem with 64bit OS.

I switch to 2.08.24 and there are no problem at all.

Hey people.
I’m trying to reproduce results from the 4-wire USB to Pro Mini atmega328 5V 16M clone setup. I’m only finding half the information I need. Is there a more detailed, maybe step by step instruction that includes info like ???

1 - What programmer do I select within the IDE? (This seems kinda important)
2 - Whats the actual default baud rate of the MiniPro clones?
3 - How to change baud rate it if it needs to be changed.
3 - I have a JTAG device, although I don’t know how to use it. Would this be helpful in getting these things programed?

A few things:
I guess 4-wire setup only. My USB to TTL doesn’t have DTR.
My USB device has the latest drivers. Its a Prolific USB-to-TTL Serial Convertor And is Windows verified. Its on COM8 as viewed with Device Manager, and is set up for 8,N,1. There is NO facillity to change DTR or RTS settings that I can find.
I’m running Windows 7 Ultimate.
I’m trying the Arduino IDE as my uploader but I’m just guessing the bauds, programmer type and a few other things I cant think of right now.
Here is some of the output (It compiles fine)

avrdude: Version 5.11, compiled on Sep 2 2011 at 19:38:36
Copyright (c) 2000-2005 Brian Dean,
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is “C:\Program Files (x86)\Arduino\hardware/tools/avr/etc/avrdude.conf”

Using Port : \.\COM8
Using Programmer : arduino
Overriding Baud Rate : 57600
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done. Thank you.

I’d like to point out it ALWAYS returns with
Using Programmer : arduino
Overriding Baud Rate : 57600

Although I’m using neither. No matter what I set the IDE settings for, it always returns that information.
Its at this point I’m trying to release the button. Actually, just at the end of compile time. But the board goes back to the one-second blink program before the LEDs ever flash on the USB-2-serial board.

I’m hoping to use these boards in an important project. Any help would be appreciated. A clear set up instruction would be VERY appreciated.

This would have to be one of the most frustrating things ever devised. A few months ago, I got it working to the point that about 1 in 5 upload attempts actually worked.

Today, 100 times. It did not work.

Im on OSX Yosemite, had the same problem with SparkFun FTDI board and SparkFun Arduino Pro Mini. This guide fixed the problem: How to Install FTDI Drivers -

Had to reboot the machine for the terminal command to work properly, and after that reinstalled the FTDI drivers. Works like a charm now.

Pressing the reset button works fine with my pro mini. Thanks a lot!

Pressing the reset button works fine with my pro mini. Thanks a lot!

Pressing the reset button works fine with my pro mini. Thanks a lot!


i have a little question about programming the mini 05 with the uno.
Is that the same way as al other Arduino minis? i see there are 2 rx and tx pins, are they the same? or must u use the pinouts on the top of this board.

Last other question, normally there is standard a bootloader on it right? Or must u upload a bootloader first the the Arduino Mini 05?

Please let me know

hold the reset button. Click upload....wait about 2-4 seconds and release reset button.

This worked for me after trying a billion things!!! I had the usb to arduino mini pro with 4 jumper wires setup correctly the very first time using it without even looking up how to hook it up tx to rx. rx to tx. grd to grd. 5v to vcc.

If there wasnt' the stupid hold reset button the blink example upload would've worked my first time!

You didn't connect the DTR pin?