New to Arduino, can't get it to connect, help very much appreciated

Hello, new to Arduino and getting very frustrated. At the point happy to pay someone to assist!

I have an Arduino nano (Duinotech) ATMega328p. It's connected via USB and lights up also the 'tx' light. However I get errors trying to upload the sketch.

Error: avrdude: stk500_getsync() attempt X of 10: not in sync: resp=

I've found a page for this and followed it, but didn't help. Tried ATMega328 Old Bootloader, and a few other things, made no difference.
Looked up Device Manager and it doesn't appear under "Ports Com and LPT' but under 'Other Devices' is 'FT232R USB UART' which appears to be the Nano. I've trued updating the driver and it starts then I get a Windows pop up error saying '...Encountered a problem, USB Serial Converter, the hash for the file is not present, the file likely corrupt.... '

Can anyone please point me in the right direction, I'm not really familiar with the above and clearly something isn't working. So much appreciated if someone could assist :slight_smile:

Update. Connected a Arduino Uno. Now in the IDE ports it says '(Com 3) Arduino Uno' and the 'Get Board info' actually gets the board info and it all worked. So clearly the port is working, just not for the Nano...

Could someone kindly help me fix all the above with the Nano?

I expect you have a non genuine nano .
These often require a CH340 driver to be installed for the USB/UART chip. Google !
Also check you are using a data type cable and not a simple charging cable ( which doesn’t have the data wires connected ) , not the case here tho !

Clicky

Have you tried the different BOOTLOADER options presented in the IDE ?
Chances are it will be either the standard or OLD BOOOTLOADER.

Hi Hammy, thank you for the response. It's a Duinotech so possibly different from the genuine Nano? I have seen some info online re CH430 driver but my Nano definitely has a ATMega328P chip, I thought the CH430 was the chip? How would I tell if that was what was in mine? Also if I install CH430 driver I won't damage or reconfigure my computer USB ports so they don't work with USB drives etc? I feel I'm playing with fire here as I barely know what I'm doing

Thanks again for your assistance

Hi Ballscrewbob - yes I tried the 'ATMega328 old bootloader' but didn't make any difference

The chip you would need to look at is usually seen on the underside of the board.
This is a CH340 clone but there are others.
The CH340 and CP2102 also need additional drivers which you can find by using the forum search as it is a common question.

Hi BSB, this is the chip in the underneath. Now I know why it comes up as FT232 USB UART in the port. Is this a CH340 chip - does this shed any light on the issue? Thanks again for your help. I wonder how many don't proceed when encountering issues like this that require a great knowledge of computers/hardware etc
If I search for FTDI or 232RL then there appears to be a number of drivers on the internet. Is this all I need? the right driver for this chip thing?

If it is exactly the same as that one then as I said they do require drivers, and the forum search will get them for you.
More often you are better trusting the links you find in here as there can be some bad driver sites out there.
In here we tend to only reference ones we trust.
On occasion that may be a Chinese site, but that's only because it is the original supplier

A clear picture of YOUR chip (unless it is the same) is always worth posting.


Hi BSB - sorry - my mistake. I had posted a picture of the chip but it didn't 'take''. Here it is

Normally that would not require drivers.
Some people have on occasion reported issues for the FTDI and it is best to get the driver direct from the FTDI site and install manually if that is the case.

So now do a forum search for "ftdi driver" but stick to the more recent ones and you should find a link pretty easily.

Hi BSB, thanks again for your interest. So you're saying normally the FT232RL wouldn't require drivers? Anyway, it sounds like it wouldn't hurt to get the latest so I'll do as you say and hunt one down.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.