New to Arduino: Error, expeced primary-expression before '=' token

Hey guys,

I'm new to the arduino board, and I'm trying to use the board to measure temperature using a thermistor. Here is my code but I keep getting this error before the double data_raw = analogRead(READING_PIN) line

#include <math.h>
#define READING_PIN = 0

double R1 = 5600; //resistance
double V_IN = 5.0;

double A = .0013;
double B = 2.5306e-4;
double C = 8.76741e-8;
double K = 0.5; // mW/dec C - dissipation factor

double Hart(double R)
{
//calculate temperature
double logR = log(R);
double logR3=logRlogRlogR;

return 1.0/(A+BlogR+ClogR3);

}

void setup(){
Serial.begin(9600);
}

void loop()
{
double data_raw = analogRead(READING_PIN);
//Serial.println(data_raw);
double V = data_raw/1024*V_IN;
Serial.print("V=");
Serial.print(V);

//calculate resistance
double R_th = (R1*V)/(V_IN-V);
Serial.print("V R_th= ");
Serial.print(R_th);

double kelvin = Hart(R_th)-VV/(KR_th);
double celsius = kelvin - 273.15;
Serial.print("Ohm - T = ")
Serial.print(celsius);
Serial.print("C\n");
delay(1000);
}

Here's your problem:

#define READING_PIN = 0

You don't use defines like that...it should be

#define READING_PIN 0

Good luck!

magagna:
Here's your problem:

#define READING_PIN = 0

You don't use defines like that...it should be

#define READING_PIN 0

Or beter yet:

const int READING_PIN = 0;

And you forgot a semi-colon.

Serial.print("Ohm - T = ");

Or beter yet:

const int READING_PIN = 0;

By convention, all capital letter names are reserved for #define'd names so that they are KNOWN not to be variables (const or otherwise). So, I disagree that that is better. Unless you change the name to mixed case.