New to the NANO 33 BLE, SENSE, IOT please read this first.

The BLE SENSE, BLE, and 33IOT have TWO COM ports.
The second COM port also often referred to as "BOOTLOADER" can be invoked by quickly double tapping the reset button.
It can also be used to help clear out a sketch that does not behave. For that simply put it into BOOTLOADER mode then upload either BLINK or BARE MINIMUM from the EXAMPLES.

The IDE knows and expects this type of action and can handle it.
Most often there is no need to chase the new COM port or to force your OS to choose another port as this can lead to further issues.

However there have been some scenarios with other boards of this nature where over aggressive antivirus, Cloud / network or portable based IDE installs can cause delays which result in some problems.
If yours is one of those types of problem then unless you have some decent knowledge of networking etc.
it is often best to uninstall the IDE and re-install to a local drive.

If you think it is antivirus / security based then you need to add the install locations to your whitelist / exclusions.
Each security program is different so no quick answer for that.

Another is USB 3.x issues. There are well known not just for Arduino but other USB peripherals too.
It can be your computers CHIPSET that may not be fully compliant. The most common fix is to insert a USB 2.0 hub between the Arduino (or errant peripheral ). This acts as a buffer in most cases

Last but not least are USB driver issues under Windows. If your USB drivers were supplied by Microsoft you should consider going to the hardware manufacturer site and getting the proper drivers as microsoft has a habit of breaking some of the drivers. This extends beyond USB with the second largest problem being Graphics card drivers supplied by microsoft.

Please rule all those aspects out first.

NEW NANOS GENERAL.

AVOID using libraries not specifically for the new NANO boards unless you are conversant with making any needed changes to the library. Instead most examples are included when you install the core files for the board.

If you cannot find a library for your new NANO then start by using the LIBRARY MANAGER from the IDE.
The keywords you need to use to whittle down the ones you want are "nano", "sense", "iot", "ble" but be sure you pick the ones from ARDUINO.

Also including a pdf that may help with some of those aspects (but not all)

SIMPLE TROUBLESHOOTING.

  • Ensure you turn off any additional security / antivirus just to test.
  • Where possible use USB 2.0 ports or a USB 2.0 POWERED HUB.
  • Try other computers where possible.
  • Try other USB leads where possible.
  • Avoid cloud based installations where possible OR Ensure your cloud based software is RUNNING.
  • Boards that use a MICRO USB plug should be both CHARGE and DATA. Many are CHARGE ONLY

Install cores
Open the IDE (1.8.5 upwards). Select TOOLS.
Install core 01.png
Select Board the Board Manager.


When the box opens up wait until it has downloaded any new or updated items.
Then in the blank box type the board you wish to install.
You do not always need the full name.

Select the correct variation and click the INSTALL option.
Please be patient and wait until it has finished.
Although not needed I often RESTART the IDE at this point.

CLEAN UP BEFORE INSTALLING ANOTHER COPY OF THE IDE OR ARDUINO CREATE.pdf (347 KB)

One thing that wasn't obvious to me: with the Nano 33 you need to use the "WifiNINA" library (install via Tools / Manage Libraries...) and #include "WifiNINA.h" instead of "WiFi.h". If you use WiFi.h, you will just get WL_NO_SHIELD errors and nothing will work.

I cannot download a driver for the Nano 33 BLE Sense board. Every variation stops with a message that the CRC doesn't match.

Hi @chuck_gaston. Please provide more details about what you were doing when you got this error. I can guess, but I'd rather not.

I have purchased two nano 33 BLE Sense boards, but can't use them yet because I can't download any appropriate board driver. From the Arduino IDE I select tools, then Board: then Boards Manager. The appropriate choice for the 33 BLE Sense appears to be "mbed-enabled boards", but both current and older versions fail to download. The "deprecated" version doesn't even start to download. The preferred versions seem to download about half-way, then stop with the message, "CRC doesn't match". I can successfully download other board drivers. A part of the message said that this may be a temporary condition, but I tried again for several days with the same result.

HOWEVER, TODAY IT WORKED! The "temporary condition" just lasted days longer than I expected.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.