New user library problems

First time arduino user, have a nano.
I installed the software and wanted to add a library for BP180.
When I try to install the library from the 'Manage Libraries' I get Crc doesn't match, File is corrupted.
This happens for any library I try to load.
I have tried this on 2 different computers, both windows, one Windows starter and one Windows Ultimate.
I did load some libraries last week without trouble.
What am I doing wrong.??

So now that I have found my solution I will post it. I am not sure why or how this happened.

My first install of the software (on my netbook) V1.6.3 was via the Windows Installer version, then updated to the 1.6.4 version in the same manner.
When I came back the next day and tried to install some other libs I got the 'checksum error'.
Today I uninstalled the software and used the 'zip' download, then tried to install the extra libs and all worked fine.
I will have to give that a shot on this machine also when I find time.
Hopefully I can get my BMP180 going soon.