Newbie having problems woth COM port, I think

First time using my uno rev3. I got "Blink" running, even changed the period. Now I'm trying to run a simple sketch to read a pulsein. It compiles ok but when I try to download it I get a message something about "unable to set com-state". I understand diddly about windows drivers and that stuff. Background: My uno just came up as COM3. Is it essential to use the same USB port all the time? I ask because I tried switching USB connector when it suddenly lost track of which COM port the uno was on. I also tried reloading the driver (when it asked me) - did that create some sort of conflict between two USB ports?

OH, and another part of the error message says it is overriding baud rate to 115200. I declared a serial rate of 9600.

Here is what I'm seeing:

Using Port : COM3

Using Programmer : arduino

Overriding Baud Rate : 115200

avrdude: ser_open(): can't set com-state for "\.\COM3"

avrdude done. Thank you.

The overriding baud rate is simply information that the programmer is increasing the baud rate for uploading only. It doesn't effect the com setting in the program.

If using windows, type "Device Manager" in the search box.

The com port of your board will be shown here:

Use that to set the port number in the IDE.

Thanks for replying. I understand now about the baud rate. However, since my first report I find that the only way I get the editor to "see" my UNO is by re-installing the whole shooting match. And again just now, I was happily modifying and downloading when suddenly the "COM3" disappeared from beside the "Arduino Uno" in the box next to the compile/download buttons. When I click to select I am instructed to select a device and a port if I wish to download, but I see no way to actually select a port, just plain old "Arduino Uno" which of course lets me compile. And this disappearance of COM3 seems to occur at the start of a download which then continues forever (hung) until I log out and back in.

Where do I kick the editor in the pants to get it to look around again and find my uno at COM3? Short of re-installing?

Also I am having trouble with the PulseIn command but I guess I will start another topic for that.

Thanks anyone for help with the above.

Oh I should mention that if I attempt to start Arduino Create by searching for the app in windows, I get told I do not have the required permissions. I have to open Firefox and google Arduino then sign in from there. ???

Not sure what is going on. But if it were me I would:

  1. Download from Nirsoft (safe) the program USBDeview.exe
  2. Remove your UNO
  3. Run USBDeview (no installation required)
  4. Delete all the devices that report "Not Connected"
  5. Reboot your computer and try again.

No guarantees but a place to start.

This program deletes all devices that were previously "found" It does not delete any files so its pretty safe.