No CLK

Hi,

Bought my serial v2.0 kit last week and assembled it. Tried to burn boot loader with AVRISP mkII. Got error message indicating that Entering programming mode FAILED! Measure on the X-tal, 16MHz, with a scope and there's nothing except a DC level. Checked soldering and measured connection between component. Any one that have any suggestions why the osc. won't swing.

/Rick

What capacitor values are you using for the oscillator? Does the value match the oscillator requirement?

well, I used the values in the schematics, 22pF. Have not checked with x-tal spec if that works!

If your Atmega chip does not have its fuses set to use a crystal then it won't oscillate. This is a fairly unlikely failure, but possible. I assume you checked the power, ground, miso, mosi, sck, and reset levels already. If the chip is fused for an external clock you will have to provide one in order to reprogram it from the ISP.

jims, you are right about the fuse bits... if the ATMEGA is programmed to use the internal clock, then the external oscillator will not oscillate...

sa7U, I think it doesn't matter what your clock source selection fuse bits are when you are programming the "fuse bits" and the bootloader using an AVR ISP programmer. I programmed hundreds of ATMEGAs using a ZIF in a separate board connected by ISP without any oscillator installed around the target AVR. Maybe I am wrong... but it is possible that your oscillator circuit is OK, and the ATMEGA is programmed to use the internal oscillator.

sa7U, what are you using to program the bootloader?

I had the same problem using an AVRISP mk2 to program an ATMega8 with the AVRstudio software.

After checking with the folks on AVRFREAKS.NET is was suggested to check the ISP clock frequency in the AVR Studio software. It seems that for the AVRISP mkII it defaults to something like 8,000Hz and this doesn’t work. If you change the frequency to something between 1 and 4 MHZ it should work–at least it did for me.

When you check the fuse/protection bits with this setup. If they won’t accept changes you’ll need to do a complete chip erase and try again.

Note that in my case it showed the same symptoms on the clock line because in the first attempt to program the SW/HW reprogrammed the fuses to use an internal clock!

Did you try following this procedure on the playground?

Hi,

Tanks for all good advise. I did use the tutorial on the playground. But still... no progress. I got an error message when I tried to enter program mode so I tried with lower ISP freq. Still no progress. I have also tried with two other Atmega8 chips just to verify that I didn't manage to burn something and measured all connections to eliminate bad soldering or shorts. Nothing! On top of that the programmer went bananas and entered some kind of programming mode that I could not recover from. So a new programmer is on the way. When I have the programmer on the desk I shall walk through the step by step instructions one more time.

/Rick

Hey

the AVRISP-MKII sometimes does go nuts and completely lose its ability to do anything. The good news is that it is pretty easy to restore it to life.

There is a procedure for updating its firmware that restores things to normal.. you have to open it and short a couple of pins with a paperclip, then you can restore the firmware through AVRStudio. A few months back I was programming about 50 Arduinos and had to restore the firmware three times!

Try this link, they explain how to do it.

D

So..., I upgraded to the STK500. And now yes I can program my Atmega8. Works fine on the STK500 board. So I erase a chip, burn down the bootloader, frogram fuses according to the guide lines and gets the led blink and so on. Then I move the chip from STK500 to the Arduino serial board. Switch on the power and absolutly nothing happens. I try with the ISP but cant get the chip into program mode. I check supplies and connections to the chip and everything seems ok. Anyone that have an idea what's going on?

/Rick

hi

do you get the three led blinks when the chip is installed int he Arduino? If not you should check the oscillator settings.

D

Hi,
Nop, I get no action at all. I have set fuses according to the guideline on the playground. But even if the chip is empty with no fuse settings at all I should be able to get contact via the ICSP IF. I use the same ICSP freq. on booth the STK500 and Arduino board.

This is the procedure:

  1. Put the Atmega8 in the STK500 and erase the device.
  2. Set fuses and loockbits and burn boorloader.
  3. Check the three led blinks, Ok.
  4. Un-plugg everything and move the chip to the Arduino board.
  5. Connect the power and a led, nothing!
  6. Try with ICSP, cant enter program mode.
  7. Checks supply voltage and ICPS signals, Ok

/Rick

Hi

do you have power connected to the Arduino while trying to program via its ISP? Sounds like the oscillator is not running.

D

Hi,

Yes, I have the power connected and No the oscillator is not running I've checked with a scope. But Do I need the osc. then I try with ISP? If i stop the osc on the STK500 I can still read and write through ISP. ISP will provide the chip with clk for the programming or...? I will try to build a board with minimum configuration just VCC, GND and ISP signals and see if that works.

/Rick

ISP does not provide clock. You need to have an oscillator, either internal or external, running at... I don't have any docs hand... let's say several times the rate of your ISP clock.

The ISP clock is only for marking the edges of the bits on the MISO and MOSI lines.

Perhaps the stk500 provides a clock on a clock in pin and your chip is fused for an external clock?