No COM Port in Arduino RP2040

I've been trying to run my new RP2040 but I can't see any COM port in my computer.
I tried the double reset; the Jump wire between GND and REC. I haven´t tried the Blink.ino.elf.uf2 because no massive storage device appears in my computer... all i said was on BETA 2.0.0.
(I used 3 different USB Cables)

In 1.8.16, when i go to boards manager... it doesn't appear RP2040 board. I have tried in 1.8.12 and the same result.

I'm using Windows 8. I didn't find any new in the forum.
Thank you for your help.

I'm not familiar with the RP2040. Usual thing to check is what your operating system (which one) thinks of your board. In Windows, use device manager; in Linux, use lsusb and dmesg.

Have you tried a different cable? It's possible that you are using a charge-only cable.

Your topic has been moved to the dedicated RP2040 section on the forum.

1 Like

Correct it doesn’t have one.

No you need to hold down the button on the board and then plug it in and then release the button. Then you should get the mass storage device after two or three seconds delay.

Have you loaded in the RP2040.board driver?

Hello, please check the following documentation.
Getting started: https://docs.arduino.cc/tutorials/nano-rp2040-connect/rp2040-openmv-setup

If you are still getting issues please get in touch with us directly.
Contact us: https://www.arduino.cc/en/contact-us/

I'll check a different one (cable) in hours... I will keep you posted. Thank you!
I didn't know about only charge cable.

I tried your suggestion about hold down the button and release it. It didn't work. Thank you for your suggestion anyways. :slight_smile:
About the board manager: In IDE 1.8.16, the Arduino Mbed OS enabled-boards doesn't show me the Arduino Connect board. Only appear Portenta H7 and Arduino 33 BLE. IDK why...
Many thanks!

You never said it was an Arduino Connect board. Anyway go to the board manager and download Arduino Mbed OS Nano Board.


Then you will find it under the Arduino Mbed OS Nano Board group of boards.

Select that, and plug it in to your computer, and you should see the board

1 Like

Arduino Connect RP2040 Doesn't appear. Even though apply the filter with RP2040 nothing is find.

My findings are:

As I said, I was using Windows 8 and apparently with an only charge cable. (Thanks @sterretje)
I got a very trashy Windows 10 computer and the arduino board worked with the @Grumpy_Mike 's suggestion (hold the button down and release)... I found the COM Port. and I was able to upload a blink sketch (little modifications in order to identify the new program) and... that´s been it.

By the way...after that I used the correct cable, the same trick in my Windows 8 and nothing happened...

I think I'll upgrade to W10.

Many thanks!

Are there other options for the RP2040? Just trying to learn in case a similar topic shows its face.

The only official Arduino board that uses the RP2040 microcontroller is the Arduino Nano RP2040 Connect.

However, there are many RP2040-based boards by other manufacturers, all of which can be used with the Arduino development software. Those include the Raspberry Pi Pico, the Adafruit Feather RP2040, the SparkFun Pro Micro - RP2040, and so on...

1 Like

Yes, just calling it a RP2040 means that it is the original Raspberry offering, The chip and the board having the same name. It was the original and like all originals there is no need to add a qualifier.

For third party boards using the chip you would say the board and the chip. So for the Arduino variant you would say "Arduino connect RP2040".

So a RP2040 just means the original Raspberry Pi.

Which board is that? When I see Raspberry Pi selling something as "RP2040", it is the bare microcontroller. Their board is called the Pico and everyone refers to it by that name.

https://www.raspberrypi.com/products/raspberry-pi-pico/