No COM ports on XP

Sorry, if this is a FAQ. I checked.
When installed the USB drives for Arduino 017 on XP everything seems to go OK but then when I looked in the Device Manager there were no COM ports. No section called "Ports (COM & LPT)". I tried on two boxes. They both have hardware serial ports. Any ideas? Thanks.

You see COM ports only when the FTDI chip is "plugged" in the USB, that is, Arduino is connected to the PC through the USB cable.

Thanks very much for your reply. I rebooted. Made sure the USB cable was connected but could not see any COM: ports in the Device Manager.

I tried version 16 but now I get error ""The required section was not found in the inf" when I try to install the driver. :frowning:

Ill be interested to see what more knowledgeable users of windows say .
Turn the computer on without the USB to the arduino plugged in .When XP stabilises then plug it in and if you get such a message then it is not finding the driver for its serial port. If it helps my driver on Windows2000Pro comes up as
All three show on page
Provider FTDI Ltd
File version

Take a step back for a second: make sure that when you plug in the Arduino via the USB cable the TX RX and LED13 flash a little. Despite the fact that it might not be able to talk to the computer yet you should still have power on the arduino, including its (super short) boot up sequence.

If not then your problems somewhere on the arduino, not in the driver.

Thanks, that was a good thing to try. I do get flashing TX and RX leds. I just tried my Arduino with a friend's Linux box and it worked OK. I was able to send the ping program and it ran. So it does seem to be my Windows setup. I also have a Fedora Linux box maybe I'll try installing the (Linux) drivers on it.

You've hit one of windows permanent bugs that noone will talk about. Windows has huge problems with usb/temporary hardware. (It has a huge design flaw in accessing permanent hardware as well).

Some things you can try are:
completely removing the drivers. That requires finding them and physically deleting them from the windows inf directory. Usually you'd find out what they are by rightclicking the hardware in device manager. You can try just reinstalling the ft232 (assuming youre using that arduuino) drivers.

Go into device manager and click "view" "hidden devices". You may well see a bunch of com or usb ports there that are "disconnected". Delete them.

You may also just have a bad usb port or cable. Try using a different usb cable.

I know how frustrating this is as ive experienced it with a lot of different types of hardware under different windows versions.

Thanks very much for all your suggestions!
I gave up on Windows and moved to Linux.
Got it working pretty quickly on Fedora 11.
In both cases (Windows and Linux) I just followed the instructions.
Oh well, at least it works somewhere for me.