No configura mi arduino

Es una copia arduino que me han regalado unos amigos. La cuestión es que instalo los drivers ch340 y instalo la ultima version del progama arduino. Escribo todo el proceso pero abajo me marca errores y me dice:

processing.app.debug.RunnerException
at cc.arduino.Compiler.callArduinoBuilder(Compiler.java:316)
at cc.arduino.Compiler.loadPreferences(Compiler.java:215)
at cc.arduino.Compiler.build(Compiler.java:174)
at processing.app.SketchController.build(SketchController.java:647)
at processing.app.Editor$BuildHandler.run(Editor.java:1739)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.io.IOException: Cannot run program "C:\Program Files (x86)\Arduino\arduino-builder": CreateProcess error=2, El sistema no puede encontrar el archivo especificado
at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
at processing.app.helpers.ProcessUtils.exec(ProcessUtils.java:26)
at cc.arduino.Compiler.callArduinoBuilder(Compiler.java:296)
... 5 more
Caused by: java.io.IOException: CreateProcess error=2, El sistema no puede encontrar el archivo especificado
at java.lang.ProcessImpl.create(Native Method)
at java.lang.ProcessImpl.<init>(ProcessImpl.java:386)
at java.lang.ProcessImpl.start(ProcessImpl.java:137)
at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
... 7 more

Alguien sabe a que es debido esto?

Verifica que JAVA este actualizado
Verifica que Windows este actualizado

Si todo esta bien y persiste
Instala de nuevo el IDE.

Muchas gracias, ahora lo probaré.