no device found

Arduino: 1.6.7 (Windows 7), Board: "Arduino/Genuino Uno"

Sketch uses 1,030 bytes (3%) of program storage space. Maximum is 32,256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.
avrdude: ser_open(): can't open device "\.\COM4": The system cannot find the file specified.

Problem uploading to board. See for suggestions.

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.

This is a new UNO replica and a new user to this form of progaming. I tried a new usb cable, same error message. Maybe something was not installed proprerly??

Maybe. Check Device Manager, make sure there is nothing with an explanation point thru. If so, fix that.

Then try the Loopback Test, see if the 16U2 (USB/Serial adapter) is responding correctly.
Then check back here with results.

"a new UNO replica" So you may have something other than Atmega16U2 for the USB/Serial adapter chip next to the USB connector.