no error by programming but only bootloader is on

hi forum,
i just resently started to work with arduino on mac os x (10.3.9) and the atmega168 on board.
everything worked perfectly fine, i was able to load all kind of different sketches on the chip
until the point where suddenly the execution of the program stoped. i disconnected all wires
and inserted a LED on pin 13. now, when the board is powered up through the USB port, the
LED on pin 13 flashes 3 times every approx. 6 seconds. according to the information on the
arduino webpage, this means that the bootloader is on board and actually ready to program.
i can load every sketch on the atmeag168 without any error, but only the bootloader causes
the LED to keep flashing three times every 6 seconds. so, the sketch doesn’t seem to be “burned”
on the chip. according to other informations on the forum, this problem can be solved by
connecting the RX pin with either a 10k or 4,7k resistor to ground. i tried this without any success.
another information on the forum is, that the RX pin needs to be connected to the TX pin. i tried
this as well but still without any further progress.
does anybody have another suggestion how i can re-load the program onto the chip?
i appreciate any help.
best, r.


the flash means the bootloader is there, waiting for a program. It flashes again because a) it didn’t find a program onboard the chip, and b) you didn’t try to reprogram it. So the diagnosis is that there is no user program burned into the chip.

Usually this is caused by not having the right processor selected in Tools> Microcontroller. Is it set to Atmega 168? also, what model of Arduino are you using: NG, Barebones etc?


dear daniel,
thanks for your reply. i already checked the microcontroller selection, it is on atmega168.
also, when i start loading the sketch to the chip, the two LED (TX and RX) flash as they do
when a sketch is “burned” on the chip. i do not get any error after the burning process is
finished. i also tried different sketches, from the one that used to be working to the simple blink
LED example on the webpage.
i use the NG arduino board on mac os x (10.3.9).
thanks for any further suggestions.


so you cannot upload any new programs? If so, no one is sure why this happens… the best explanation so far seems to be that it is possible that the fuse settings were corrupted by a low-voltage at some point.
IF so, you need a new chip, or you have to reprogram the chip with a new bootloader. You can order a burned chip from or, or for about $5.


PS: Do not connect the RX to TX pin, this is very bad advice, as the TX pin can short into the RX pin when the TX is high and the RX is low.

hi daniel,
in the meantime i ordered some new pre-programmed (with a bootloader on it) 168
microcontroller. now, when is insert such a new chip, i can burn a sketch only once.
that means, once i have i.e. the blink led example on the chip, the led will flash
on pin 13 but the next time i try to load another sketch on the same chip, it will give
me the same error as i had a few days ago with the other (old) avr chip (programmer
is not responding). further more, i get the answer, that the “Atmel AVR ATmega168 is found”,
that there is a “Firmware Version of 1.16” but that the “Programmer is not responding”
i appreciate any ideas why that happens.
best, r.

rroo, please post Arduino IDE version you are using and also the version or model of the Arduino board (NG, Diecimila, etc)

sorry, i use a NG board (13239) and arduino-0008. all under mac os x (10.3.9)
and a atmega168.
thanks for any suggestions.