No I2C device found... help!? YwRobot LCM1602 IIC V1

Hi all, very new to all of this, but I’m totally stuck and would really appreciate any advice to help me move forward.

This is my first Arduino project and I’m struggling to figure out how to get this LCD working…

lcd

I’ve tried several different I2C scanners and always the same result… No I2C device found… when i fire it up and try to run an example code like hello world or even the I2C scanners, i see 2 lines of white(ish) squares on a dark blue background. I have the MEGA2560 and I’m using A4 and A5, which i’ve tried reversing just incase, but no change. If these are the wrong pins, i have not been able to find any info regarding alternate pins…

It took me forever, but i think i finally found where the libraries are stored on mac (el capitan) and have tried removing the built in liquid crystal library and adding the newest version (1.3.4) of the “new” liquid crystal library (via library manager) from fmalpartida at the bitbucket, but to no avail. I don’t know where to go from here and am starting to wonder if maybe i just got a lemon? I’ve attached a photo of the lcd with backpack incase that’s helpful. Also, I’ve been trying to follow as much of the advice on this thread as possible as it seems to be one of the more comprehensive I’ve found… still no luck.

If anyone has any advice, it would be so very much appreciated.

Thanks,
Joe

A4, A5 are the I2C pins on a UNO. (SDA, SCL)
Since you have a Mega2560, you should use the SDA, SCL pins for a Mega2560.

David.

OMG... Thanks David...