No Icon after uninstall and install on Ubuntu 20.04

I am having difficulties with IDE installation, I will try to explain what happened:

I was running the Arduino IDE 1.8.15 on Ubuntu 20.04 64bits... then I have a "great idea" to upgrade to 1.8.19
I run ./ without errors. I deleted the 1.8.15 folder, and made a restart. All looks as expected.

I downloaded the new 1.8.19 version, unpacked at Downloads folder.
I run ./ also without errors, but after that, there is no Android icon to run.
I have checked the /usr/share/applications and there is an arduino-arduinoide.desktop there,
and there are some arduino-arduinoide.png at usr/share/icons/../apps

Running the ./arduino runs the 1.8.19 IDE as expected.

It looks similar to

but closed without solution

any ideas to recover the icon on applications screen?


I wouldn't bother with it. Just run the arduino script directly, either via the command line or the file manager.

I see people wasting a lot of time fighting with that stupid installation script and I never see anyone end up being successful in the end. I have never had an interest in it so I can't provide any advice if you are set on using it.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.