No luck with Arduino Mega 2560 and SIMCOM SIM900 connectivity .

Hi there,
Recently, I bought this gsm module "Geeetech SIMCOM SIM900" but I am unable to connect to it. I have browsed this forum and lot of others but my issue seems to be very cumbersome.

What i have done:
-I am using this popular "software serial library" on pins 10=rx & 11=tx on Mega2560.
-Using 5v, 1.2 Ampere adapter for power supply to sim900.
-NetLight blinks every 3 seconds, showing that it is onto my gsm network.
-Set jumpers to SWserial side because i am using 10,11 pins. [D7 and D8 for Uno as you may know,On Mega they turn out to be D10 and D11 as they support interrupts.]
-Connected grounds.
-Tried AT\r commands to let sim900 module detect autobauding [read somewhere to do that.].
-Using baud rate of 19200 [Even tried some others by repeated coding.]
-Used carriage return '+CR'

What is problem?
-No communication, not a single byte more than this letter "þ"! Thats only when I start the module.
-Two rough beep tones heard when pressing power button.[Not clear at all!]

I am not new to Arduino and software serial lib. I have used same library to connect to gps modules and other devices like two Arduinos.

But this problem has come like hell on me.
If it were not the NetLight blinking every 3 seconds, I would have taken this module for 'damaged' by now.

What could be the problem? is there something I am missing?
Is there any other way to communicate with this device? Can this device be reset? Any upgrading of its firmware?

I have used following code: simplest i may say.

#include <SoftwareSerial.h>

SoftwareSerial mySerial(10,11);

void setup()
  mySerial.begin(19200);               // the GPRS baud rate   

void loop()
  if (mySerial.available())
  if (Serial.available())


Please let me find luck out this disappointment. Anybody?

There's a working example in the link in my signature.

I have tried that one too. Sending "AT" gets me nothing.


After lot of trouble, my last hope & try proved to be fruitful!

As it turns out that somehow firmware of SIM900 got corrupt or don't know what was wrong with it.

I upgraded/refreshed its firmware and now it works perfect, as it was never messy.

I have discussed my problem and solution in my blog. In case, if anybody has same problem, please refer to:

That's not the first thing you would expect.

Thank you for the feedback, I'll keep your blog bookmarked.

Hi, could you post a photo of your set-up? (hardware).

I try with many ways, but I don't know why it doesn't work