No Mac serial port choices. Only Bluetooth. Sad I can't use my Arduino Uno.

No relevant serial ports are listed in Tools > Serial Port > .
Only listed ports are /dev/tty.Bluetooth-PDA-Sync, /dev/cu.Bluetooth-PDA-Sync, /dev/tty.Bluetooth-Modem, /dev/cu.Bluetooth-Modem.
Tried all of them. Always the same orange in arduino console. “processing.app.SerialException: Serial port ‘/dev/tty.Bluetooth-Modem’ already in use. Try quiting any programs that may be using it.”

or if no bluetooth port is selected: “processing.app.SerialNotFoundException: Serial port ‘COM1’ not found. Did you select the right one from the Tools > Serial Port menu?”
Using Snow Leopard 10.6.8 on MacBook Pro, all software up to date via software update.

The Uno worked on my PPC G5 for the past year. The “solution” to “just use the G5” is no longer an option.
Never had a “Network detected” dialog when plugging in Arduino Uno on Snow Leopard 10.6.8 on MacBook Pro.
Changed out 4 different USB cords, all tested in working order. All USB ports directly on the computer were tried.
When connected the Uno green “ON” LED is on and “L” LED is flashing most likely due to “Blinking Light” (File > Examples > Basic > Blink) example currently running and was uploaded from the PPC G5.

Tried IDE’s arduino-1.0.1, arduino-1.0.2, arduino-1.0.3, arduino-1.5.2b.
Tossed out /Users/user1/Library/Arduino/preferences.txt and /Users/user1/Library/Preferences/cc.arduino.Arduino.plist
Tried IDE’s arduino-1.0.1, arduino-1.0.2, arduino-1.0.3, arduino-1.5.2b.
Tried restarting the IDE with the board connected to the computer and also connecting before IDE start.

All firewalls were off. Went thru the Activity Monitor and force quit anything that might hold USB ports, example Image capture. They do start right back up.
Tried this http://www.cmiyc.com/blog/2012/10/08/arduino-fixing-serial-port-in-use/
ls -l /var/lock
sudo mkdir /var/lock
sudo chmod 777 /var/lock

Opened “Get Info”, tried “Open using Rosetta”, liberated the user permissions.

Uno R3 version .0001 purchased from Sparkfun.com 12-2011. Stock UNO, no modifications, nothing connected but the USB cord.
Pointless but I installed the FTDI drivers.
The Uno is selected in Tools > Board

Uninstalled my usrobotics 56K USB Modem model 5637 from network preferences.
I have turned off bluetooth in System Preferences. Tried all the above. I have turned on bluetooth in System Preferences. Tried all the above.

From USB menu on “System Profiler”
Communication Device:

Product ID: 0x0043
Vendor ID: 0x2341
Version: 0.01
Serial Number: 64935343533351801222
Speed: Up to 12 Mb/sec
Manufacturer: Arduino (www.arduino.cc)
Location ID: 0x3d100000 / 2
Current Available (mA): 500
Current Required (mA): Unknown (Device has not been configured)

I’ve scoured the troubleshooting forums and http://www.arduino.cc/en/Guide/Troubleshooting#upload, and googled and googled and googled. I really appreciate the input but no one has a solution. Like so many other Mac users on 10.6 to 10.7 with the loss of serial port choices, I’m disappointed that I can’t use my Arduino. Perhaps an option would be to use a bluetooth/wifi interface but I feel for now I’ve lost the faith.

Serial Monitor Output:
processing.app.SerialException: Serial port ‘/dev/tty.Bluetooth-Modem’ already in use. Try quiting any programs that may be using it.
at processing.app.Serial.(Serial.java:171)
at processing.app.Serial.(Serial.java:92)
at processing.app.SerialMonitor.openSerialPort(SerialMonitor.java:207)
at processing.app.Editor.handleSerial(Editor.java:2481)
at processing.app.Editor$17.actionPerformed(Editor.java:665)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2028)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2351)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
at javax.swing.AbstractButton.doClick(AbstractButton.java:389)
at com.apple.laf.ScreenMenuItem.actionPerformed(ScreenMenuItem.java:95)
at java.awt.MenuItem.processActionEvent(MenuItem.java:650)
at java.awt.MenuItem.processEvent(MenuItem.java:609)
at java.awt.MenuComponent.dispatchEventImpl(MenuComponent.java:343)
at java.awt.MenuComponent.dispatchEvent(MenuComponent.java:331)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:713)
at java.awt.EventQueue.access$400(EventQueue.java:82)
at java.awt.EventQueue$2.run(EventQueue.java:669)
at java.awt.EventQueue$2.run(EventQueue.java:667)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:98)
at java.awt.EventQueue$3.run(EventQueue.java:683)
at java.awt.EventQueue$3.run(EventQueue.java:681)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:680)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Gammon Forum : Electronics : Microprocessors : Debugging using SPI/I2C and a second processor
Like so many other Mac users on 10.6 to 10.7 with the loss of serial port choices, I’m disappointed that I can’t use my Arduino. Perhaps an option would be to use a bluetooth/wifi interface but I feel for now I’ve lost the faith.

I’ve got OS/X 10.7.5 and my Arduinos appear correctly. In this screenshot I have a couple plugged in, plus a couple of FTDI cables:

This is how it appears in the System Profile:

I don’t know what to suggest, though. Reboot? Check for OS updates?

shakyspoon: Always the same orange in arduino console. "processing.app.SerialException: Serial port '/dev/tty.Bluetooth-Modem' already in use. Try quiting any programs that may be using it."

The Bluetooth port is part of your Mac and has nothing to do with the Arduino. The default for the IDE is to pick something. However, you'll never communicate with your Arduino this way.

shakyspoon: All firewalls were off. Went thru the Activity Monitor and force quit anything that might hold USB ports, example Image capture. They do start right back up. Tried this http://www.cmiyc.com/blog/2012/10/08/arduino-fixing-serial-port-in-use/ ls -l /var/lock sudo mkdir /var/lock sudo chmod 777 /var/lock

While I'm glad you found that, the problem is completely unrelated. Something is preventing your serial port to be properly enumerated. The "already in use" is because the IDE is trying to use a port unrelated to the Arduino.

shakyspoon: Perhaps an option would be to use a bluetooth/wifi interface but I feel for now I've lost the faith.

You can't program the chip over WiFi and Bluetooth is problematic since it doesn't usually do auto reset.

The problem is your Mac isn't assigning a serial port to the Arduino.

Are you connecting the Arduino though a USB Hub? (Keyboards count as a Hub).

As already noted this is an OS problem. The port should appear (only when the Arduino is physically connected) as a pair of files /dev/tty.usbmodemXYZ and /dev/cu.usbmodemXYZ. The IDE gets its list of available ports from the OS.

There are utilities that may help your diagnosis, perhaps the standard Utility->Console will show some meaningful error message when you connect the Arduino. USB Prober is a dedicated tool available from the Mac developer site, and you may find downloadable copies around. I'm saying this because apparently some people solved their "device not recognized" problems just by running a low-level usb analyzer (???). I would also get rid of the FTDI drivers, just in case.

I run OSX 10.6.8 on a MBPro and have the same Vendor/Product/Version IDs, never had similar problems so far.

Thanks for the input! You guys got me thinking, I have my laptop setup with 2 partitions, I use the work partition all the time and I use the maintenance partition for running disk utilities and such on the work partition. The maintenance partition only has the default and software updated 10.6.8 with some additional maintenance utilities installed. So I booted to the maintenance partition, installed IDE Arduino 1.0.3, plugged in the Uno board and viola, the new Network device Detected dialog popped up. I uploaded some tests and the Uno works fine & dandy. But all my stuff is on my work partition so this setup would suck. I rebooted back to the work partition, as per your suggestion checked the console messages after plugging in the board:

2/26/13 8:01:57 AM com.apple.kextd[10] Can’t load /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBCDC.kext - no code for running kernel’s architecture.
2/26/13 8:01:57 AM com.apple.kextd[10] Failed to load /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBCDC.kext - (libkern/kext) requested architecture/executable not found.
2/26/13 8:01:57 AM com.apple.kextd[10] Load com.apple.driver.AppleUSBCDC failed; removing personalities.

Interesting differences between my work partition and my maintenance partition of file ‘/System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBCDC.kext’
My work partition
Kind: Kernel Extension (PowerPC)
Size: 356 KB on disk
Created: Saturday, August 1, 2009 12:52 AM
Modified: Saturday, August 1, 2009 12:52 AM
Version: 3.1.5, USB CDC driver

My maintenance partition of the same System extension file but from a clean install of 10.6.8:
Kind: Kernel Extension (Intel)
Size: 123 KB on disk
Created: Saturday, August 1, 2009 12:52 AM
Modified: Saturday, August 1, 2009 12:52 AM
Version: 4.0.5, USB CDC driver

Some strange differences. I copied ‘/System/Library/Extensions/IOUSBFamily.kext’ from the maintenance partition to the desktop of my work partition.
1st I duped then replaced the direct problem “/System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBCDC.kext” with the same file from the maintenance partition. No go, nada, Nothing. No “new network interface Detected” dialog.

Then figured I’ll replace the whole dang extension:
08:31:51 PM Tue Feb 26, 2013:/System/Library/Extensions user1 }[O]<===o sudo mv IOUSBFamily.kext/ IOUSBFamily.kext.ORIGINAL/
08:32:36 PM Tue Feb 26, 2013:/System/Library/Extensions user1 }[O]<===o sudo cp -r ‘/Users/user1/Desktop/IOUSBFamily.kext from user2 - 10.6.8/IOUSBFamily.kext’ .

The board was still plugged in and BOOM! there was the “new network interface Detected” dialog. Hit Network Preferences, then Apply, booted up the IDE, Tools > Serial Port and I am good to go! Thanks!!!
Just hope I didn’t break something else.
USB Drivers that I recall installing. I’m sure there were others.
USRobotics zoom modem
Logitech mouse drivers

Nice job troubleshooting the issue. Glad you got it to work.

I had the same problem of no Mac port to choose for the MEGA 2560. (MAC OSX, 10.8.5 )

SOLUTION: 1) Fired the Arduino 1.0.5 , Connected the Arduino to a USB port

1) I went to tools/BOARD and choose (don't ask me the rationale) another BOARD model which has the choice of serial ports

2) went to tools/SerialPorts and selected /dev/tty.usbmodem621

3) went back to tools/BOARD and selected the right one (i.e., MEGA 2560).

Everything is working…

Don't ask me why….

I have the same problem, the MacBook Pro does not recognise any port for Arduino Uno R3.
the arduino is for controlling a CNC machine, and the Atmega chip is “burned” with hex(grlb) file.
tried connecting in windows (VMware) and no connection also. installed the ftdi drivers and still nothing works, don’t know how to instal the USBprobe.
really not an expert on this matter, just want make this work.
anyone can help me with a simple solution :slight_smile:

spatula: ... I would also get rid of the FTDI drivers, just in case.

Can someone please tell me where I can find the FTDI drivers on Mac OS Mountain Lion so I can get rid of them?

I am also looking for the D2XX drivers and a SiLabsUSBDriver, which was recommended in another forum on this topic, so I can get rid of those and start over.

I gather from this forum that I never needed those drivers so I'd like to get rid of them. I'm 3 days in and still can't get IDE to show a port for UNO. The port did appear once, but then disappeared. I'm trying to go back to the beginning and recreate what I did to get it to appear.

OS: Mountain Lion Model: iMac early 2008 Arduino: UNO (just the UNO board, nothing else attached) IDE: 1.0.5

Thanks!

UPDATE: I found and removed all drivers using Easy Find.

Please disregard.

I have this exact problem. Does anyone have a solution for it? I tried as suggested above selecting another board and changing the ports but it didn't work for me. I have also installed the drivers.

Thanks,

Alex

I just had almost the exact same experience as shakyspoon (original post), want to share how I solved it.

My computer crashed while uploading to a Diecimila. When I rebooted the serial ports in the Arduino IDE were all bluetooth. I tried using the Processing sketch by Tom Igoe (http://processing.org/reference/libraries/serial/Serial_list_.html) to list all the available ports but it only found the bluetooth ones as well. Also, when I plugged the board in I did not get the “Network detected” dialogue box anymore.

I did find some Console error messages referring to the IOUSBFamily.kext

To fix it I tried…

  • switching to a different board in the Arduino IDE (just like dchialvo’s post above), that didn’t work.

  • verifying and fixing permissions on my hard disk, that didn’t work.

  • resetting the SMC, that didn’t work.

  • resetting PRAM, that didn’t work.

  • reinstalling the entire Operating System, that didn’t work.

Finally, I just tried plugging in a different Arduino board, my Arduino Uno. Suddenly the USB serial ports were back in the Arduino IDE. Then I unplugged the Uno and plugged the Diecimila back in and the USB serial ports remained!

I have no idea if the other stuff I did helped, but at least it’s working again.

I’m using Mac OS 10.6.8 on an old MacBook, with Arduino IDE 1.0.5

When I had the exact same problem it turned out my UNO had no boot loader. Took it back to Maplin and it worked 1st go with a new one!

Hi everybody, I’m having the same problem, but I’ve not a second partition to check.

the weird thing is that until this night I’ve always worked with this system (Mac OSX 10.9.5) without problem, but now I can’t see serial ports from my usb input.

I use without problems usb drive but arduino, panstick and a board I builded from myself, not anymore!

They are presents in hardware list as usb hardware, just the /dev/tty.usbmodem* address is not created, so that Arduino and other serial reader didn’t notice them.

I installed new FTDI driver this morning, trying to solve that problem, and then I removed them, but nothing to do.

I'm having the same problem on Mac 10.10 with an Uno and IDE 1.6.4. No tty anything, just cu.

Help!I am having the same problem with my serial port.I am using the arduino uno,Mac 10.6.8,and IDE 1.0.6.But I have a guess what the problem might be.I downloaded the library for "Make an arduino controlled robot",and ever since I have had the bluetooth serial port problem.Can anyone tell me if this is causing the problem and how to fix it!

The same problem I solved with a new, thicker usb cable

I have seven arduinos -- 3 yuns and, 2 unos and 2 mega 2540s. I have a macbook air running the latest version of yosemite (10.10.5) and using arduino IDE 1.6.8.

No problems with the unos, megas or 2 of the yuns. When I attach the boards via the usb port and in the terminal window do a cd /dev followed by an ls command, I get.

tty.Bluetooth-Incoming-Port tty.Bluetooth-Modem tty.usbmodem1411

This matches what I see in the IDE app under tools/ports. I can upload via the usb port, or in the case of the yuns upload via the wifi.

HOWEVER, when I connect the third arduino yun, I only see:

tty.Bluetooth-Incoming-Port tty.Bluetooth-Modem

in the terminal window and in the arduino IDE. Merely swapping the board to any another one of the seven, the tty.usbmodem1411 port returns in all places. All is well. Swapping in the third on, and only bluetooth. I have reflashed the third board, reset the wifi and other processor and the open-wrt all in my experiments to understand what has changed on the third board. It is consistent and does not change. All other boards work, and continue to do so.

I am convinced this is not a mac problem. There is something going on on the third arduino yun.

Any thoughts?

I’ve come across this problem a couple of times and in both times the resolution depended on the board.

The first Arduino Uno R3 board appeared to be legitimate, but came from a different vendor. I have documented the steps that solved this below as ‘Scenario A’ and ‘Scenario B’:

======================
Scenario A

  1. Install the CH340 driver
  2. Remove the FTDI drivers from my mac. Apple recently installed a new utility that prevents removal of what it considers to be critical components. The process that enforces this rule is called csrutil. You’ll have to disable this process to remove the FTDI driver. Then you’ll need to re-enable it when you are done. This required a restart in recovery mode. Here’s how to do that:

a.) power off the mac then hold ‘command’+R during the restart until the image of the apple appears.
b.) when the screen refreshes, click on ‘Utilities’ menu then 'Terminal.
c.) type csrutil disable
d.) Hit enter
e.) Restart

  1. remove the FTDI drivers with the following command:

sudo rm -R /System/Library/Extensions/AppleUSBFTDI.kext

Type in your password when prompted.

  1. Restore the apple csrutil by following steps a and b above. Task c will be the same EXCEPT you’ll type this instead:

csrutil enable

Then follow steps d and e.

When you restart the arduino IDE, you should see a more comprehensive list of ports besides just the bluetooth port.

======================
Scenario B

This board was an import and clearly not an original Arduino/Genuino. Attempts to load sketches resulted in this lovely error:

Using Port : /dev/cu.usbmodem1421
Using Programmer : arduino
Overriding Baud Rate : 115200
avrdude: ser_open(): can’t open device “/dev/cu.usbmodem1421”: No such file or directory
ioctl(“TIOCMGET”): Inappropriate ioctl for device

There was only one Port listed in the IDE, dev/cu.Bluetooth-Incoming-Port.

It had been a while since Scenario A had occurred and since then I’d installed a few OS updates. Checked the drivers and low and behold, the darned FTDI drivers had RETURNED!!

I repeated the steps in scenario A above but the problem remained.

Then I installed an updated board configuration from arduino and it worked! Testing on the first board I’d used under scenario A were successful as well. Here’s what I did:

  1. In the IDE go to Tools-> Boards → Boards Manager
  2. I installed 'Arduino SAM Boards (32-bits ARM Cortex-M3) by Arduino version 1.6.8
  3. Unplugged and replugged the USB cable into my arduino.
  4. In the IDE go to Tools → Port. The /dev/cu.usbmodem1421 was listed as a port option. Selected that.
  5. Uploaded my sketch.
  6. Bask in glory of SUCCESS!

I hope this was helpful to you. I spent two days on Scenario A and 3 hours on Scenario B.
"

Consider the possibility that you have a Chinese Arduino clone, which doesn't use FDTI, but a CH340G chip for the serial communication. In that case, you will need a special driver for Mac's to be able to talk to your Uno/Mega/Nano.

Check for the driver and more information here:

http://kig.re/2014/12/31/how-to-use-arduino-nano-mini-pro-with-CH340G-on-mac-osx-yosemite.html