No me reconoce la YUN REV2 en ningún COM USB

Muy buenas, he estado utilizando una placa YUN REV2 en un portátil HP con Windows 10 pro sin problemas, hasta que quise ejecutar un programa para probar las interrupciones en el pin 2. A partir de esa prueba no hay manera de que me reconozca la placa en ningún COM USB del portátil ni de otros ordenadores. El port 5353 UDP no está bloqueado, y al ejecutar la IDE 2.0.0-beta.9, en la casilla de selección de Board aparece Arduino YUN pero no consigue localizar la placa en ningún COM USB, porque cuando conecto la placa Windows me da el mensaje "No se reconoce el dispositivo USB"

Primero bienvenido al foro Arduino en Español.
Agradezco que hayas informado con qué IDE estas trabajando.
Te recomiendo que mires el Administrador de dispositivos a ver si tienes algo en Amarillo con un Warning o Advertencia referido a este USB-COM.
Lo siguiente sería que te bajes una versión IDE no beta, un portable si quieres para probar si ocurre lo mismo.
Si todo falla o en el orden que gustes busca otro cable USB. Todo funcionaba hasta recién pero ahora no funciona, asi ocurre todo en electrónica. Prueba con otro cable USB y nos comentas.

Hola Surbyte, gracias por contestar tan rápido.

  • Ya había probado con IDE no beta. El mismo resultado.
  • Ya había probado con otros cables. El mismo resultado.
  • También había probado directamente conectar la placa sin tener el IDE arrancado. El mismo resultado.
    Sólo me falta mirar el Administrador de dispositivos. Lo miro y te digo el qué.
    Un saludoi,

Puedes comunicarte via ssh con Putty o algo similar?
Otra mas, desactivaste el AntiVirus, el puerto 5353 dices que no esta bloqueado, como lo has comprobado?

Mira esto que es justamente de donde extraje estas sugerencias.

Hola Surbyte, ahora tengo conectada la placa a un COM USB del portátil, sin ejecutar el IDE, y efectivamente en Administrador de dispositivos, en el bloque Controladoras de Bus Serie Universal hay un dispositivo que indica:

Dispositivo USB desconocido (Error de solicitud de descriptor de dispositivo)

que al clicar sobre él indica este estado:

Windows detuvo este dispositivo porque informó de problemas. (Código 43). Error en una solicitud del descriptor de dispositivo USB.

¿Puede ser que el problema esté en la propia placa? ¿Que haya perdido alguna información interna?

Hola Surbyte, en mi antivirus veo la regla que permite el tráfico de UDP en el puerto 5353, entrante y saliente.

Comprobaré la comunicación via ssh con Putty o algo similar y miro el link que me has pasado.

Gracias,

Bueno esto dice a las claras que tu chip USB esta fallando.
Como es similar al Leonardo tienes un Atmega32U4 responsable de la comunicación USB.
Una posibilidad es que haya perdido su programación.

Mira este hilo que luego conduce a tu solución o eso creo (no tengo Yun)
https://forum.arduino.cc/t/arduino-yun-not-responding/343663
Que conduce a la razó por la cual se desconecta el Atmega32u4 y es porque como has dicho esta haciendo algo luego de tu código en el que generaste la interrupción, ahora suena mas lógico.

Seeing Yun in IDE Port menu

HardwareArduino Yún