'no member named init' how can I stop this from appearing,

The code is:

//add ChainableLED library to this project
#include <ChainableLED.h>

//set the number of leds linked to the chain
#define NUM_LEDS 1

/assign leds as the name of
the ChainableLED set the
pin of the ChainableLED to
pin7(clock pin) and pin8(data pin)
and number of the leds
/
ChainableLED leds(7, 8, NUM_LEDS);

//naming pin3 as lineFinder
#define lineFinder 3

void setup() {
// initialize the digital pin as an input:
pinMode(lineFinder, INPUT);
//initialise ChainableLED leds
leds.init();
}

Could anyone please help me.

Thank you

the error is:

Arduino: 1.8.12 (Windows 10), Board: "Arduino Uno"

C:\Users\super\Documents\Arduino\Grove_Beginner_Kit_Sketchbook-master\tutorial 5 - Line Detector\3_LineDetectorSwitch\3_LineDetectorSwitch.ino: In function 'void setup()':

3_LineDetectorSwitch:23:8: error: 'class ChainableLED' has no member named 'init'

leds.init();

^~~~

exit status 1
'class ChainableLED' has no member named 'init'

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preference

Learn how to use the ChainableLED library properly. You will likely find examples demonstrating how to use the library in the Arduino IDE under something like File > Examples > ChainableLED.

In order to provide any more specific assistance, we'd need to be able to look at the library. Please post a link (using the chain links icon on the forum toolbar to make it clickable) to where you downloaded that library from. Or if you installed it using Library Manger (Sketch > Include Library > Manage Libraries in the Arduino IDE or Libraries > Library Manager in the Arduino Web Editor) then say so and state the full name of the library.

We'll also need you to provide a link to where you downloaded the Grove_Beginner_Kit_Sketchbook from.

The problem is with the .init() function. Please confirm that the function exists and is valid in the library. And try installing the latest version of the library form GitHub.

..Arnav

double check that the library you installed is this one: ChainableLED