No network connections after upgrading firmware

Hello, I am having problems with me Arduino Yun. It was not reading ok some serial info i was sending and i thought i could upgrade the firmware.

I did it following the instructions in this website, using the web version, not the console version to upgrade.

Everything looked fine, until it finished and I couldn't connecto to any network anymore. Not using wifi and not using ethernet. The white small led which used to turn on everytime when I play around with the yun, now is always off. I reset the Yun many times using the 3 different buttons but nothing worked. I am thinking i killed the network of my yun because i thought updating the firmware again, since the IDE can upload sketches and is working, but only the network is not working and I cant upgrade again because i need ethernet or wifi to try it.

Does anyone know other way to upgrade firmware without network?? I hope somebody can help me because without that, I've got an Arduino Uno hehehe. thanks

I think my Arduino Yun is an Arduino UNO now. I tried to reflash it but using any method I need wifi or ethernet connection, there is no way to reflash it without that.

The sketches can be uploaded but the Linino side is not working. Even i tried the method which voids the waranty (whatever it means), it doesn't work because i need an IP address. AAAAAAAA I dont know what to do, there is no solution if I dont have connection..... I've got an Arduino UNO very nice

It took me a while to get it just right but I had to redo the whole firmware bootloader thing.

This got me started but be careful as some of the info is slightly wrong.

The thing I got stuck on was step 7 below as the file name on the newer firmware is different and I didnt spot it for a while.

re flash YUN

Set up FTP server.

  1. obtain prompt on YUN in serial monitor (that took a few tries)

  2. ping FTP ping (my IP yours may be different do this to check FTP is up)

  3. set server ip setenv serverip; Command to set FTP server IP

  4. set yun ip setenv ipaddr; Command to set YUN IP

  5. FTP file tftp 0x80060000 openwrt-ar71xx-generic-linino-u-boot.bin; FTP file in

  6. do file system erase 0x9f000000 +0x40000;
    cp.b $fileaddr 0x9f000000 $filesize;
    erase 0x9f040000 +0x10000

  7. flash kernel tftp 0x80060000 openwrt-ar71xx-generic-yun-16M-kernel.bin; (check file name !!! )

  8. flash pt 2 erase 0x9fEa0000 +0x140000;
    cp.b $fileaddr 0x9fea0000 $filesize;

  9. reboot bootm 0x9fea0000

At this point YUN should be fixed again so try SSH into it. (check IP first and use that in PUTTY or similar)

User root
password arduino

You should also be able to get back into the web interface too but I can only get it with an IP and not a URL