No Port to select greyed out?

I’ve got an Arduino UNO installed in an out building controlling a solar panel pump and diverter valve with 3 temperature sensor inputs. I’ve adjusted the code and went to upload it from my laptop to the Arduino UNO and I get an error message saying port not available. When I try and select a port it’s greyed out and I can’t select it. I built the board and run tests on it in the house using a desktop PC windows 10 and it was fine, but for some reason it won’t upload from the laptop running windows 8? The boards soldered to a relay board which is now wired in and would be a pain to remove and bring back in the house to reupload hence why I need to use the laptop. I’ve also got no wifi coverage in the outbuilding so i have to keep unplugging the laptop and coming inside to use the web which is a pain. I’ve tried reinstalling the Arduino software on the laptop but I still can’t get the port option to select. Any ideas?

I’ve gone in to device manager and I can’t find com ports anywhere. I tried the Bios setting in case they need to be turned on but there are virtually no setting in there apart from Boot order and hard drive stuff. It’s an Advent Monza V100 if that helps. I’ve never really done much with windows 8 so I’m totally lost where to find things?

Did you install the correct driver for your UNO? Is it an Arduino product? if not, you will need to know what the chip closest to the USB connector is, provide the info. from the chip, or use google to find the driver.

When I originally set it up last year and wrote the code on my windows 10 PC I just downloaded the Arduino software and installed it and it connected straight away 1st time.

I’m not interested in what you did or did not do last year. Please provide the information requested.

I was just saying I didn’t need to install any special drivers when I originally connected it, so why would I now? I think the chip nearest the USB is 16U2

I think you are just frustrated that things don’t work as they should. That’s the nature of Murphy’s Law. To solve a problem, you must look for things you took for granted.

  1. Did you ever use your win 8 laptop for any type of arduino programming, especially programming that particular arduino, before you posted this thread?
  2. Do you have an identical spare Arduino without any of the wiring etc at your disposal? If not, get one. Apparently this project is important to you. A spare is cheap. If you do have one, try it on your win 8 laptop in your lab where you have wifi so you could install driver when prompted.
  3. Does your laptop play the “usb device plugged in” chime when you plug in your in-field arduino?
  1. I don’t think i used the windows 8 laptop for any Arduino programming as i built and tested it on the windows 10 laptop.
  2. Unfortunately i don’t have a spare Arduino they are both installed in outbuildings away from the house and wifi. I will order a spare one as I i need 1 for a future project.
  3. the laptop plays the USB device plugging in chime when I connect it so it recognises something I’ve tried all 3 USB posts on the laptop. they all don’t allow me to select post but they all play the chime when plugged in.

Best to have spares even for your future projects. This isn’t really a technical problem regarding arduino. Hope you find the right solution to this problem. Lots of solutions but I don’t want to make assumptions such as you could just buy a 200 USD win 10 laptop and spare arduinos and do in-house tests first or take out the deployed arduino and put it back. That’s a good goal for your next iteration, to design your system so the arduino can be easily taken out and replaced for any reason.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.